Announcement

Collapse
No announcement yet.

Attach Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Attach Problem

    Hello,
    My users reported that they were unable to attach files. I did a test and this is what it said.

    Warning: filesize() [function.filesize]: open_basedir restriction in effect. File(/tmp/phpH5Ln0m) is not within the allowed path(s): (/home/) in /home/revo7/public_html/forum/admin/functions.php on line 1751
    I checked the functions.php, on that line it says(and lines below):
    $filesize=filesize($attachment);
    if ($maxattachsize!=0 and $filesize>$maxattachsize) {
    // too big!
    @unlink($attachment);
    eval("standarderror(\"".gettemplate("error_attachtoobig")."\");");
    exit;
    }
    Im not sure what is wrong.

    Any help would be greatly appreciated.

    -Mike

  • #2
    Upload the phpinfo.php file from the 'extras' directory of the zip file to your forums directory. Then post the URL here. This will help us troubleshoot the problem.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      http://revo7.com/forum/phpinfo.php

      I know the server's admin pretty well, anything that needs to be changed I should be able to get done.

      Comment


      • #4
        Well the easiest thing would be to have him remove the open_basedir restrictions he's placed in php.ini.

        Failing that to get uploads to work you need to create a 'tmp' subdirectory under the 'home' directory and chmod it to 777. Then in the Admin CP set "Upload In Safe Mode?" to 'Yes' and point the "Safe Mode Temp Directory" to that directory. If you placed the tmp directory in the right place, the path to the Safe Mode Temp Directory will be:

        /home/tmp
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X