Announcement

Collapse
No announcement yet.

"Upload In Safe Mode?"

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • "Upload In Safe Mode?"

    Hi,

    Our host had to turn PHP in safe mode and now when we try to attach files it gives error messages.

    In the options for upload i put this:
    - Upload In Safe Mode? Yes
    - Safe Mode Temp Directory : /vb/tmp
    -Allow Image Size Checking Failure? Yes

    I upload the tmp folder in the /vb folder where the forum is and chmod it to 777

    When i try to attach files it gives this error:
    Warning: move_uploaded_file() [function.move-uploaded-file]: SAFE MODE Restriction in effect. The script whose uid is 32005 is not allowed to access / owned by uid 0 in /home/xxx/public_html/vb/admin/functions.php on line 1763
    Warning: filesize() [function.filesize]: SAFE MODE Restriction in effect. The script whose uid is 32005 is not allowed to access / owned by uid 0 in /home/xxx/public_html/vb/admin/functions.php on line 1767
    What can we do or tell the host to do?
    Last edited by Arsenik; Wed 7 May '03, 1:36pm.

  • #2
    Upload the phpinfo.php file from the 'extras' directory of the zip file to your forums directory. Then post the URL here. This will help us troubleshoot the problem.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Here is the phpinfo:
      ...
      Last edited by Arsenik; Wed 7 May '03, 1:31pm.

      Comment


      • #4
        Make sure you are using the correct absolute path to the tmp direcotry on the server. I doubt it is:

        /vb/tmp

        It's probably something like:

        /home/yourlogin/www/vb/tmp
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by Steve Machol
          Make sure you are using the correct absolute path to the tmp direcotry on the server. I doubt it is:

          /vb/tmp

          It's probably something like:

          /home/yourlogin/www/vb/tmp
          You are correct It works now. Thanks for your help.

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X