Announcement

Collapse
No announcement yet.

Editing php.ini

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Editing php.ini

    Have been reading through these forums trying to solve this avatar issue we've been having.

    It would seem that we may have open_basedir problems I think. PHP info here: http://www.arsclan.net/info.php

    The problem is that the avatars seem to be accepted, but appear as only broken image links...see top post here for sample: http://arsclan.net/forum/showthread.php?s=&postid=28262

    Now, when I try to edit our php.ini file to change that open_beasdir setting, it just doesn't take. I make the change and save, but it never shows up in the info file.

    We're running Windows 200 server with the latest PHP/MySQL stuff.

    Does the open_basedir seem to be the problem? Any other suggestions?

  • #2
    I think you have to restart Apache or IIS (whichever one you are using) for the changes to take effect.

    Comment


    • #3
      Originally posted by Jakeman
      I think you have to restart Apache or IIS (whichever one you are using) for the changes to take effect.
      Thanks Jakeman, we're using IIS and I did try restarting it a few times along with rebooting the machine. Some changes I make take effect right away, but this one and a few others seem locked.

      Any other ideas?

      Comment


      • #4
        It's possible you need to set an upload_tmp_dir variable in php.ini as well. You'll need to specify a directory on your server that is world-writable.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by Steve Machol
          It's possible you need to set an upload_tmp_dir variable in php.ini as well. You'll need to specify a directory on your server that is world-writable.
          Indeed, and thank you too Steve.

          This is another variable that I looked at and attempted to edit, but with the same results as the open_basdir entry...won't take.

          I guess there are actually 2 issues here; 1. The main avatar problem, 2. This php.ini problem. I'm working under the assumption that solving 2 may solve 1, but if someone here tells me otherwise, I'll pursue another solution.

          Note: I am able to upload custom avatars via the control panel. They get transferred and displayed properly in the Avatar section there, but do not appear in the user CP. I'm wondering now if maybe this php variable is not the ussue.

          If so, perhaps a mod can edit the title of my thread! I guess I should have focused on the primary issue itself, rather than pursuing the unproven solution.

          Comment


          • #6
            Are you editing the correct file and restarting the web server afterwards?

            C:\WINNT\php.ini
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Originally posted by Steve Machol
              Are you editing the correct file and restarting the web server afterwards?

              C:\WINNT\php.ini
              Yes, php.ini located in the winnt directory. Have restarted both IIS and the computer itself after various edits to no avail.

              Comment


              • #8
                Fill out a support ticket at:

                http://www.vbulletin.com/members/support_form.php

                Be sure to include the login info to your Admin CP and root telnet or ssh access to the server.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X