Announcement

Collapse
No announcement yet.

Cookies Question...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cookies Question...

    Is there someway I can completely turn cookies off. I want to force users to log into the forum each time they visit.

    thanks

  • #2
    You can force the "Automatically login when you return to the site" setting by editing a couple templates.

    To force this preference when a user registers, edit your registeradult and registercoppa templates:

    Replace:

    <tr>
    <td bgcolor="{firstaltcolor}"><normalfont><b>Automatically login when you return to the site? (uses cookies)</b></normalfont></td>
    <td bgcolor="{firstaltcolor}"><normalfont>
    <input type="radio" name="cookieuser" value="yes" checked> yes
    <input type="radio" name="cookieuser" value="no"> no
    </normalfont></td>
    </tr>

    with:

    <tr>
    <td bgcolor="{firstaltcolor}"><normalfont><b>Automatically login when you return to the site? (uses cookies)</b></normalfont></td>
    <td bgcolor="{firstaltcolor}"><normalfont>
    <input type="hidden" name="cookieuser" value="no"> no
    </normalfont></td>
    </tr>

    To prevent them from changing this option later, remove this from your modifyoptions template:

    Remove:

    <tr>
    <td bgcolor="{firstaltcolor}"><normalfont><b>Automatically login when you return to the site? (uses cookies)</b></normalfont></td>
    <td bgcolor="{firstaltcolor}"><normalfont>
    <input type="radio" name="cookieuser" $cookieuserchecked value="yes"> yes
    <input type="radio" name="cookieuser" $cookieusernotchecked value="no"> no
    </normalfont></td>
    </tr>

    To update this option for all current users, run this query on your database:

    UPDATE user SET cookieuser=0

    Backup your database before querying it!

    Comment


    • #3
      thank you for your reply

      I did as you suggested. However, I have a user testing it for me. He uses op sys 98se. He has saved his userid and password to windows. He does not get prompted to log in - automatically enters the forum.

      For myself, the above suggestion works. I did not save my userid and password to windows.

      Comment


      • #4
        You have to do the same as above for nosessionhash, including the query:

        UPDATE user SET nosessionhash=0
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Just curious, why would you want to do this?

          Comment


          • #6
            ok - did that too. Same thing. This user says he does not get prompted to log in.

            Comment


            • #7
              Have the user completely close his browser and relaunch it.

              If that doesn't work, have him close his browser and manually delete the cookies for your site.

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X