Announcement

Collapse
No announcement yet.

Pruning Threads Timeout

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Pruning Threads Timeout

    Hi,

    When I try to prune threads older than 90 days on all forums it doesn't seem to do anything and eventually gives me a timeout message relating to functions.pl.

    Any ideas?

    Thanks,
    Kez

  • #2
    'functions.pl'

    What the specific error message?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      It's now giving me a different error: Fatal error: Maximum execution time of 30 seconds exceeded in /home/domains/soccerpages.com/user/htdocs/forum/admin/db_mysql.php on line 93

      Comment


      • #4
        You'll need to edit php.ini and increase the max_execution_time variable.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Or you could try placing one or both of these lines (changing 60 to whatever you want) just after the <?php in admin/global.php

          ini_set("max_execution_time", "60");
          set_time_limit(60);

          Comment


          • #6
            Originally posted by fury
            Or you could try placing one or both of these lines (changing 60 to whatever you want) just after the <?php in admin/global.php

            ini_set("max_execution_time", "60");
            set_time_limit(60);
            I added these lines in global.php:

            <?php
            ini_set("max_execution_time", "90");
            set_time_limit(90);

            I now get this error:

            Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 5941 bytes) in /home/domains/soccerpages.com/user/htdocs/forum/admin/functions.php on line 1449

            Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 11 bytes) in Unknown on line 0

            Where do I find php.ini? I am running on a shared db server - do I have to ask my host to change this? They generally don't make any changes to stuff like this

            K

            Comment


            • #7
              Your host would need to make any changes to php.ini. The location of that file is in your phpinfo.php page.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Originally posted by Steve Machol
                Your host would need to make any changes to php.ini. The location of that file is in your phpinfo.php page.
                Just got this reply from my host:

                Dear Customer,
                We will not change the memory allocation limit as this would allow people to abuse server resources. My apologies for any inconvenience that this may cause.


                Comment


                • #9
                  Sorry but this is really beyond our control.

                  The only thing I can suggest is to prune posts in smaller batches.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Pruning in smaller batches worked...thanks

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X