Announcement

Collapse
No announcement yet.

Server Move Problem, still!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Server Move Problem, still!

    Before the message I was getting implied that the software could not connect to the DB.

    I had someone look into it and he did the following:

    globalized the server, user, and password values, took out the pipes in the mysql_connect function and replaced them with the actual variables

    Now it's still giving me a "Database Error" message except now it lists no further information and the boards software is not dispatching an email to the technical error email address. So now I think the software is connecting tom the db.

    Any ideas what can be causing this? Would anyone be interested in making a few dollars and attempting to fix this for me?

  • #2
    Right-click on the error page and go to View/Source. Then copy-n-paste the error message here.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      <!-- Database error in vBulletin :
      cannot use database gotfina_com_-_vbulletin
      mysql error: Access denied for user: '@localhost' to database 'gotfina_com_-_vbulletin'
      mysql error number: 1044
      Date: Tuesday 29th of April 2003 01:09:59 AM
      Script: /forum/
      Referer:
      -->

      Comment


      • #4
        This error means either:

        1. One or more of the following is wrong in your config.php file:

        $dbusername
        $dbpassword
        $dbname

        If you are unsure of what the appropriate values are then you will need to ask your web host.

        2. Or that this db user is not assigned to that database or does not have permission to access MySQL to create a database. You may need to first manually create the database and assign the db user to it. Since each web host is different, if you do not know how to do this then contact your web host for help.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          globalized the server, user, and password values, took out the pipes in the mysql_connect function and replaced them with the actual variables


          ???
          They changed other files then the config.php which should just have the user/pass/dbname/host in it ?

          Revert all changed files to default vBulletin files and adjust your config.php to reflect the right changes.

          host: localhost (or the ip to the mysql server)
          tip: if not localhost, make sure the remote connection is allowed for that mysql

          user: the username for the mysql database, not your ftp login

          pass: the password for this username for the mysql database, not your ftp login

          database name: the name of the database that has been made to store the vbulletin stuff in.

          Comment


          • #6
            Originally posted by xiphoid
            ???
            They changed other files then the config.php which should just have the user/pass/dbname/host in it ?
            Yes, they changed the db_mysql.php file as well. As soon as I get home I'll change them back to the copies I have on my desktop.

            However, I assume I'll be getting the same error message I was before he changed them -- after I checked to make sure all the DB users, passwords and names were correct.

            Comment


            • #7
              Originally posted by Mr H
              Yes, they changed the db_mysql.php file as well. As soon as I get home I'll change them back to the copies I have on my desktop.

              However, I assume I'll be getting the same error message I was before he changed them -- after I checked to make sure all the DB users, passwords and names were correct.
              Someone familar with VB fixed it for me. Steve, from what he said I believe you were right. I don't know what I was doing wrong!

              I appreciate the help everyone offered

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X