Announcement

Collapse
No announcement yet.

missing the uid?!!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts
    TripleH
    Senior Member

  • TripleH
    replied
    wow, didn't realize they were that important...

    Leave a comment:

  • Steve Machol
    Former Customer Support Manager

  • Steve Machol
    replied
    Those damn "."s will get you every time!

    Leave a comment:

  • Morgalis
    Member

  • Morgalis
    replied
    thanks for the offer... i dug around until i found it

    i removed some hacks today that were server intensive due to the load, but i had missed a vital "." in a sql statement

    now i am totally fixed on both parts.. thanks steve!

    Leave a comment:

  • Morgalis
    Member

  • Morgalis
    replied
    i digress

    this now occurs for each person

    Leave a comment:

  • Steve Machol
    Former Customer Support Manager

  • Steve Machol
    replied
    If you have not installed any hacks, fill out a support ticket at:

    http://www.vbulletin.com/members/support_form.php

    Be sure to include the login info to your Admin CP and FTP.

    If you have installed hacks, then remove the hacks first before filling out the support request.

    Leave a comment:

  • Morgalis
    Member

  • Morgalis
    replied
    indeed there were discrepancies! thank you for the script

    i ran the script, and double checked that there were now the same amount of entries, but i still have this problem.. i even updated the counters just in case, but nada

    again, it is not something that is wide spread, but it's happened to some important users

    i did confirm that the entry is in the dbase and there is one for the same id in the userfield

    anything else?

    Leave a comment:

  • Steve Machol
    Former Customer Support Manager

  • Steve Machol
    replied
    This problem may be due to the user and userfield tables no longer matching. There should be one entry for each user in both tables. You can verify this by using phpMyAdmin to access and view your database. If they don't match then you can use the script posted here to fix the problem:

    http://www.vbulletin.com/forum/showt...984#post248984

    Leave a comment:

  • Morgalis
    Member

  • Morgalis
    replied
    addendum that i felt i should add seperately

    i just did a search on all posts and there are many people in this category and when i hoved over their link, it has the userid of 0

    there are some people that were removed and are now set to guest, but others i can search in my dbase for and it still finds them

    really not sure what has caused this

    Leave a comment:

  • Morgalis
    Member

  • Morgalis
    started a topic missing the uid?!!

    missing the uid?!!

    something i am encountering and not quite sure why

    Upon editing certain users, i find that their UID is not showing up when i hover over the links

    eg:

    send pm
    posts
    forum access
    remove user

    but it does show up on View Profile

    if i go to edit one of these users, i get this error

    Database error in vBulletin Control Panel 2.3.0:
    Invalid SQL: SELECT userid
    FROM user
    WHERE username='MillenniuM'
    AND userid <>
    mysql error: You have an error in your SQL syntax near '' at line 4
    mysql error number: 1064
    Date: Wednesday 16th of April 2003 08:24:56 PM
    Script: http://www.diabloworld.com/forums/forums/admin/user.php
    Referer: http://www.diabloworld.com/forums/ad...on=edit&userid=*****


    i don't see any correlation between these users or a common denominator

    suggestions?
    Attached Files
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X