Announcement

Collapse
No announcement yet.

Our forum slowed to a crawl....

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Our forum slowed to a crawl....

    I just transferred our main site to its own dedicated server. The server is a P4 - 2.0ghz machine with 1.5ghz ram. Since the move we are seeing excruciating processing latency. When you click a link, it takes anything from 5 - 20 seconds for the next page to appear. I'm not referring to page load time, it just takes that long for the next page to appear in any shape or form.

    I did install mod_gzip on the server but have now commented it out of httpd.conf due to many complaints of it not caching images in IE. The server is a new Plesk server and came with php4.1.2 and I'm presently building the RPM for 4.3.2. More config info here.

    The last server had 4.2.2 and processing latency was about 1.5 - 2 seconds which I think is pretty normal. The forum is very important for us and is an integral part of our business and it's not much at the moment:

    http://hostnexus.com/forum

    Any help is much appreciated.

    Also, I took a db dump, uploaded it to a test database on a domain on the same server and used vb2.3.0 files to test some things. Now our main forum says it's 2.3.0 when it isn't - it's still 2.2.6 - very weird.
    • Laurence Flynn – In our EIGTH year of great hosting!
    HostNexus - #1 Web Hosting Provider
    • Plesk 8 LINUX Hosting Solutions brought to you by HostNexus - the Multi-Domain Specialists!

  • #2
    Are you sure you need PostgreSQL, DBX and a lot of other modules in PHP loaded? Might think about optimizing the server somewhat and slimming down what is available if you don't need every single module except Oracle connectivity running on the system.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API

    Comment


    • #3
      Originally posted by NexDog
      I just transferred our main site to its own dedicated server. The server is a P4 - 2.0ghz machine with 1.5ghz ram. Since the move we are seeing excruciating processing latency. When you click a link, it takes anything from 5 - 20 seconds for the next page to appear. I'm not referring to page load time, it just takes that long for the next page to appear in any shape or form.

      I did install mod_gzip on the server but have now commented it out of httpd.conf due to many complaints of it not caching images in IE. The server is a new Plesk server and came with php4.1.2 and I'm presently building the RPM for 4.3.2. More config info here.

      The last server had 4.2.2 and processing latency was about 1.5 - 2 seconds which I think is pretty normal. The forum is very important for us and is an integral part of our business and it's not much at the moment:

      http://hostnexus.com/forum

      Any help is much appreciated.

      Also, I took a db dump, uploaded it to a test database on a domain on the same server and used vb2.3.0 files to test some things. Now our main forum says it's 2.3.0 when it isn't - it's still 2.2.6 - very weird.
      to start with can you please provide the following

      1. is this on dedicated or shared virual server
      2. your server specs. For example:

      cpu speed/type single or dual cpus): dual p3 1ghz
      how much memory installed: 512mb ram
      hard drive type/configuration: 60GB EIDE non raid
      linux distributor or windows version: redhat linux 7.3
      apache/IIS version: apache 1.3.27
      PHP version: php 4.3.1
      MySQL version: mysql 3.23.56


      3. if you use mysql 4.x instead of mysql 3.23.x, do you have any innodb type databases/tables on your server ?
      4. if possible how mysql was compiled/installed
      5. your top stats
      6. your mysql configuration variables located at /etc/my.cnf or c:\my.cnf if on Windows server if you don't have that file you need to log into telnet and as root user type

      mysqladmin -u root -p variables

      copy and paste output here

      7. your mysql extended-status output either still telnet as root user type

      mysqladmin -u root -p extended-status

      copy and paste output here

      or preferred is to installed extended-status output script which is either located

      - in your vB 2.2.6 or higher vB version's zip file extra's folder, upload mysqlinfo.php script to your site or if you're on an pre vB 2.2.6 install go to
      - http://vbulletin.com/forum/showthread.php?threadid=3477 and install that scrip making sure to edit $mysqllogin line with your own mysqlusername and password

      and post url to that here

      8. oh and is your vB the only thing on the server? or other scripts? sites?

      9. how many average and max concurrent users on your vB forum ?

      10. create a file named phpinfo.php and place this code in it and post the url/link to it from your web site

      <?
      phpinfo();
      ?>

      i.e. yourdomain.com/phpinfo.php

      11. if you run Apache and you have your own dedicated server or access to your httpd.conf (apache configuration file) can you post the values you have set for the following :

      KeepAlive
      MaxKeepAliveRequests
      KeepAliveTimeout
      MinSpareServers
      MaxSpareServers
      StartServers
      MaxClients

      12. what version of vB are you running ?
      :: Always Back Up Forum Database + Attachments BEFORE upgrading !
      :: Nginx SPDY SSL - World Flags Demo [video results]
      :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

      Comment


      • #4
        Sure, would it be better to open a ticket on this?
        • Laurence Flynn – In our EIGTH year of great hosting!
        HostNexus - #1 Web Hosting Provider
        • Plesk 8 LINUX Hosting Solutions brought to you by HostNexus - the Multi-Domain Specialists!

        Comment


        • #5
          Submitted a ticket....
          • Laurence Flynn – In our EIGTH year of great hosting!
          HostNexus - #1 Web Hosting Provider
          • Plesk 8 LINUX Hosting Solutions brought to you by HostNexus - the Multi-Domain Specialists!

          Comment


          • #6
            okay i've replied to the ticket and we can take it from there
            :: Always Back Up Forum Database + Attachments BEFORE upgrading !
            :: Nginx SPDY SSL - World Flags Demo [video results]
            :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

            Comment


            • #7
              Thanks George.
              • Laurence Flynn – In our EIGTH year of great hosting!
              HostNexus - #1 Web Hosting Provider
              • Plesk 8 LINUX Hosting Solutions brought to you by HostNexus - the Multi-Domain Specialists!

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X