Announcement

Collapse
No announcement yet.

2.3.0 & Custom Avatars

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2.3.0 & Custom Avatars

    My users are not able to upload their own avatars. When they do they receive the invalid image error. I am not able to do it either. When I choose to change their avatar to a custom one it says Avatar Updated!, but nothing gets uploaded and the avatar does not change.

    I searched the forums and saw the thread on stuff to delete in the functions.php file. Is this still the case for 2.3.0 or has it been fixed and I'm experiencing a different issue?

    Sean

  • #2
    Originally posted by Baseball Fever
    My users are not able to upload their own avatars. When they do they receive the invalid image error. I am not able to do it either. When I choose to change their avatar to a custom one it says Avatar Updated!, but nothing gets uploaded and the avatar does not change.

    I searched the forums and saw the thread on stuff to delete in the functions.php file. Is this still the case for 2.3.0 or has it been fixed and I'm experiencing a different issue?

    Sean
    have you set the path to upload to a directory that is chmod'ed to 777 ? check that first. If you have openbase_dir restrictions, you might need to have this folder in a sub folder of your forums folder.
    My Sites :

    Comment


    • #3
      Yes.

      In the SAME folder where admin & images & mod is I have a folder called tmp. That folder is set to 777. I also tried putting one the same folder in the /admin folder, set it to 777, and still no go. I've deleted the latter one. Perhaps I'm doing something wrong here?

      I ftp the avatar I want into this folder (also tried it in the plain ole avatars folder). I then modify the user. I select Change Avatar. Then were it says, "You can enter an URL of the avatar" I put:

      http://www.baseball-fever.com/tmp/1996ring.gif

      I then click Submit modifications and get the notice that it worked. It does not (but the link above is real - the graphic is there).

      In the VBulletin options I have the enable avatars to yes, the minimum custom posts to 0 (zero), allow uploads to yes, allow website uploads to yes.

      In the upload options I've tried Safe Mode as Yes and No. It is now set as Yes as my host does run in Safe Mode. The Safe Mode Temp directory says /tmp

      So I remain stumped....

      Sean

      Comment


      • #4
        Upload the phpinfo.php file from the 'extras' directory of the zip file to your forums directory. Then post the URL here. This will help us troubleshoot the problem.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by Steve Machol
          Then post the URL here.
          Consider it done:

          http://www.baseball-fever.com/phpinfo.php

          Comment


          • #6
            want to provide a test account ? save me registering, and i'll check your boards, with the upload option and that url for the image you said earlier.
            My Sites :

            Comment


            • #7
              Originally posted by pablo
              want to provide a test account ?
              Sure.

              Username: Tester
              Password: 123

              Comment


              • #8
                the error i get is
                The uploaded file is not a valid GIF or JPG file. Please ensure that it is and try again.
                do you have upload in safe mode enabled or disabled ?
                My Sites :

                Comment


                • #9
                  You have open_basedir restrictions on your server. To get uploads to work you need to create a 'tmp' subdirectory under your /home directory and chmod it to 777. Then in the Admin CP set "Upload In Safe Mode?" to 'Yes' and point the "Safe Mode Temp Directory" to that directory. If you placed the tmp directory in the right place, the path to the Safe Mode Temp Directory will be:

                  /home/tmp
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment

                  Loading...
                  Working...
                  X