Announcement

Collapse
No announcement yet.

Overhauling a vBulletin install and other questions...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Overhauling a vBulletin install and other questions...

    Hey, I've been running vBulletin for a long while and love it. I haven't really reverted most of the templates since my original install many many versions ago, and lately I feel like the look is getting old and wanted to completely overhaul it. However, I have a very active community and would rather not have to shut it down or have them see changes as I fiddle with them.

    My question is I was thinking the only way to do this would be to reinstall vBulletin into a directory somewhere else on the domain no one has access to, and make changes on that version. Then switch the MySQL database it uses when I'm done and delete the original version. I'm not sure if this would be violating the license or if it's even the smartest way to work on a live board, so I figured I'd ask.

    On another note, I've also been having major problems with my forum registration emails. Seems like many domains, particualrly AOL never get the emails that should be sent out automatically. I assume it's being filtered somehow, but was wondering if there's a bug or something anyone knows about. Regardless, anyone know how I can correct the issue.

    Thanks for the help.

  • #2
    Originally posted by Misteraven
    Hey, I've been running vBulletin for a long while and love it. I haven't really reverted most of the templates since my original install many many versions ago, and lately I feel like the look is getting old and wanted to completely overhaul it. However, I have a very active community and would rather not have to shut it down or have them see changes as I fiddle with them.

    My question is I was thinking the only way to do this would be to reinstall vBulletin into a directory somewhere else on the domain no one has access to, and make changes on that version. Then switch the MySQL database it uses when I'm done and delete the original version. I'm not sure if this would be violating the license or if it's even the smartest way to work on a live board, so I figured I'd ask.
    as far as i know its ok to do this, just put it in a directory called testvb, and restrict access to it with .htaccess.
    My Sites :

    Comment


    • #3
      Originally posted by pablo
      as far as i know its ok to do this, just put it in a directory called testvb, and restrict access to it with .htaccess.
      Does it make sense to do it this way, or is there another way to change template pages to test them without having your users see you doing it and without shutting the forum down (which would still hint at changes being made).

      Comment


      • #4
        Originally posted by Misteraven
        Does it make sense to do it this way, or is there another way to change template pages to test them without having your users see you doing it and without shutting the forum down (which would still hint at changes being made).
        don't have them user selectable until you are ready to show them off. Have a private forum with the test templates are used , and only allow admin access to it.
        My Sites :

        Comment


        • #5
          Originally posted by pablo
          don't have them user selectable until you are ready to show them off. Have a private forum with the test templates are used , and only allow admin access to it.
          OK, I'll do that then.

          Any idea about the email problem i mentioned?

          Comment


          • #6
            Originally posted by Misteraven
            OK, I'll do that then.

            Any idea about the email problem i mentioned?
            Another question... If I do install it a second time. Once I get it up and running, if I delete the original install and rename the directory on the new one to what the old one was (so my users' bookmarks still work) will that kill the script, or can I change any paths in a config file?

            Or, if I create a custom template set, is it possible to export and later import it into the original install?

            Thanks for the help.

            Comment


            • #7
              Originally posted by Misteraven
              Another question... If I do install it a second time. Once I get it up and running, if I delete the original install and rename the directory on the new one to what the old one was (so my users' bookmarks still work) will that kill the script, or can I change any paths in a config file?
              that should work, just be careful about the images, and avatar files , etc. And make a backup just incase, like
              move current forums >> backup
              move testvb >> current forums name

              make sure you don't let access to the non 'live' forums to other people
              Originally posted by Misteraven
              Or, if I create a custom template set, is it possible to export and later import it into the original install?

              Thanks for the help.
              its stored in the database, so it will be already there for you!

              if you are only editing templates, just created a new template and create the 'design forum' as i mentioned. don't bother with new files.
              My Sites :

              Comment


              • #8
                Originally posted by Misteraven
                Any idea about the email problem i mentioned?
                have you hacked anyfiles ? if not the best thing to do is submit a support ticket.
                My Sites :

                Comment


                • #9
                  Originally posted by Misteraven
                  On another note, I've also been having major problems with my forum registration emails. Seems like many domains, particualrly AOL never get the emails that should be sent out automatically. I assume it's being filtered somehow, but was wondering if there's a bug or something anyone knows about. Regardless, anyone know how I can correct the issue.
                  Are any vB email functions working? If so, you will need to view the mail logs on the server to see what happened to those emails. Once vB sends it to PHP it's in the hands of the server. If you are on a shared server you may need to ask your host to look through the logs for you.

                  For what it's worth I get a lot of bounced emails from people who's mail boxes are full, 'unavailable' or over quota. This is a particular problem with hotmail and yahoo accounts. Unless you are on a dedicated server and can set where these bounce messages go, you will never see them. The mail logs will have a record of these though.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Originally posted by Steve Machol
                    Are any vB email functions working? If so, you will need to view the mail logs on the server to see what happened to those emails. Once vB sends it to PHP it's in the hands of the server. If you are on a shared server you may need to ask your host to look through the logs for you.

                    For what it's worth I get a lot of bounced emails from people who's mail boxes are full, 'unavailable' or over quota. This is a particular problem with hotmail and yahoo accounts. Unless you are on a dedicated server and can set where these bounce messages go, you will never see them. The mail logs will have a record of these though.

                    The mail function does work, it's just some people claim to never get them. I tested it myself and was able to recreate it with AOL which is where 90% of the complaints come from. It doesnt bounce, and appears to send correctly. It just never arrives at the recipient.

                    As far as the previous question on re-installing a second copy so I can work on... I just tried a reinstall and got the follwing error on step 4.

                    Code:
                    Database error in vBulletin Installer :
                    
                    Invalid SQL: ALTER TABLE access ADD UNIQUE (userid,forumid)
                    mysql error: Access denied for user: '[email protected]' to database 'vbulletin_test'
                    
                    mysql error number: 1044
                    
                    Date: Thursday 10th of April 2003 04:41:38 PM
                    Script: /forum_test/admin/install.php?step=4&resetdatabase=yes
                    Referer: [url]http://www.12ozprophet.com/forum_test/admin/install.php?step=4&resetdatabase=yes[/url]
                    Kinda strange considering I uploaded the same config.php file (I changed the database it's pointing to). Also, this is my own server, so I do have root access to it.

                    Comment


                    • #11
                      This error means either:

                      1. One or more of the following is wrong in your config.php file:

                      $dbusername
                      $dbpassword
                      $dbname

                      2. Or that this db user is not assigned to that database or does not have permission to access MySQL.

                      As for the email issue, you will need to look at the mail logs to investigate this.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        Originally posted by Steve Machol
                        This error means either:

                        1. One or more of the following is wrong in your config.php file:

                        $dbusername
                        $dbpassword
                        $dbname

                        2. Or that this db user is not assigned to that database or does not have permission to access MySQL.

                        As for the email issue, you will need to look at the mail logs to investigate this.

                        That's very odd. Like I said it's the same config file as the live forum except it uses a different sql database. I administer both servers and know for fact it's the correct user name. What I dont understand is why it says "[email protected]". www is our webserver (192.168.1.6) and sql is our database server (192.168.211) which is what I reference in the config file. I even tried using the IP and got the same error.

                        Any ideas?

                        Comment


                        • #13
                          Another thing is the fact that though it dies at step 4, it does show:

                          Creating table access

                          Altering access table

                          When I check SQL, I can see the database is created as well as the first table so it's certainly connecting.

                          Comment


                          • #14
                            I'm still stuck on this. I believe its an issue with version 2.3.0 because after I upgarded my live forum, I started getting errors.

                            Anyone have any ideas about this? Any admins willing to take a shot at it?

                            Thanks.

                            Comment


                            • #15
                              Fill out a support ticket and be sure to include your FTP User and Pass as well as PHPMyAdmin User and Pass...

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X