Announcement

Collapse
No announcement yet.

SQL error...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SQL error...

    Every so often - in other words not every post - I will get a message from the board saying:

    Code:
    Database error in vBulletin 2.3.0:
    
    Invalid SQL: SELECT COUNT(threadid) AS total FROM thread WHERE postuserid= 
    mysql error: You have an error in your SQL syntax near '' at line 1
    
    mysql error number: 1064
    
    Date: Monday 10th of March 2003 04:24:07 PM
    Script: http://myhome.net/forums/forums/show...s=&threadid=45
    Referer: http://myhome.net/forums/forumdisplay.php?s=&forumid=22
    I have checked the Showthread.php and forumdisplay.php and i can't see anything wrong with htem.
    Also i have checked the Db and again that appears to be fine...

    But if I check the correspoding message I get the same error message.
    I can still post to the boards - as can every one else but the a little later it will happen again.

    Any advice would be greatfully recieved...

  • #2
    Reupload your original showthread.php file overwriting the one you currently have on your server. Make sure to upload in ASCII Transfer Mode!

    Comment


    • #3
      Tried that and the same error message appears?

      Comment


      • #4
        That should of fixed the problem. Since it did not, reupload all of vBulletin's original files overwriting the ones you currently have on your server.

        Once again, make sure to upload in ASCII Transfer Mode.

        Comment


        • #5
          Tried that as well.
          But it is still happening - seems to be a problem when an "unregistered" person has posted a message???


          Just fixed it, it was a corrupt functions.php - I redownloaded vb and used that one and it was fine - suspect it was faulty all along - dam firewall corrupst zips occasionally!
          Last edited by fredwest; Tue 11th Mar '03, 6:48am.

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X