Announcement

Collapse
No announcement yet.

'too many connections' and switching to dedicated hosting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Steve Machol
    replied
    Yes, but be careful with Notepad. Make sure that wordwrap is turned off.

    Leave a comment:


  • YeXL
    replied
    Originally posted by Steve Machol
    The critical factor is the number of MySQL users on the server at one time, and the number allowed in my.cnf. You can try turning persistent connections off in your config.php:
    PHP Code:
    // use persistant connections to the database
    // 0 = don't use
    // 1 = use
    $usepconnect 0
    Sorry for asking a dumb question. I got too many connections error too and stumble upon this thread for the solution. Is this what i do to turn off persistent connections?

    1) download config.php from virtual server
    2) change 1 to 0 in notepad
    3) upload and overwrite in ASCI mode?

    Leave a comment:


  • Steve Machol
    replied
    Edit my.cnf and increase max_connections:

    set-variable = max_connections=xxx

    ...with xxx being the number of connection your want to allow. Restart MySQL after making this change.

    Leave a comment:


  • tribedude
    replied
    Originally posted by Steve Machol
    Yes:
    I have my own dedicated server so I guess I am the the host. Have turned off persistant connections How do I

    "ask your host to raise the maximum number of connections they allow"

    What more must I do to increase connections...

    Leave a comment:


  • Steve Machol
    replied
    Yes:

    Originally posted by Steve Machol
    But if you still have problems after that, all you can do is ask your host to raise the maximum number of connections they allow. With a dedicated server you will have more control over this.

    Leave a comment:


  • Robink
    replied
    OK, I get this error too..

    Persistant connections is OFF.

    Is there anything else I can do? Anything I can do without asking my Host to do something?

    Leave a comment:


  • TeKnIcIaN
    replied
    Originally posted by globalinsites
    Thanks. I will ask my host. But do you think it is normal that I have these problems on a virtual account with six sites? I mean, is it reasonable to complain about these performance time-out and database error problems or would that be unreasonable because with six vbulletin sites on a virtual account things are bound to go wrong?
    Using persistant connections is a recipe for disaster. With a 30-minute connection time-out, my mysql server reached max connections several times with only two boards running (although they were quite popular).

    Since turning off persistant connections (I even disallowed it in my php.ini), I haven't had the problem show up once.

    DOWN WITH PCONNECT!!

    Leave a comment:


  • globalinsites
    replied
    Originally posted by Steve Machol
    The critical factor is the number of MySQL users on the server at one time, and the number allowed in my.cnf. You can try turning persistent connections off in your config.php:
    PHP Code:
    // use persistant connections to the database
    // 0 = don't use
    // 1 = use
    $usepconnect 0
    But if you still have problems after that, all you can do is ask your host to raise the maximum number of connections they allow. With a dedicated server you will have more control over this.
    Thanks. I will ask my host. But do you think it is normal that I have these problems on a virtual account with six sites? I mean, is it reasonable to complain about these performance time-out and database error problems or would that be unreasonable because with six vbulletin sites on a virtual account things are bound to go wrong?

    Rik.

    Leave a comment:


  • Steve Machol
    replied
    The critical factor is the number of MySQL users on the server at one time, and the number allowed in my.cnf. You can try turning persistent connections off in your config.php:

    PHP Code:
    // use persistant connections to the database
    // 0 = don't use
    // 1 = use
    $usepconnect 0
    But if you still have problems after that, all you can do is ask your host to raise the maximum number of connections they allow. With a dedicated server you will have more control over this.

    Leave a comment:


  • 'too many connections' and switching to dedicated hosting

    Hi,

    I have 6 vbulletin sites that are on the same server on a virtual hosting account.

    I get thousands of database error e-mails daily and my server slows up all the time so my sites are not available and the error that I copied below appears. I am now considering to switch to dedicated hosting, again all six sites would be on one server but in this case my own server which only will have my sites. My host says that these problems will defenately not occur with dedicated hosting. Is that true? I suppose there is a limit to the number of visitors that can be online at the same time before the errors occur?

    Regards,

    Rik.







    Warning: Too many connections in ... on line 40

    Warning: MySQL Connection Failed: Too many connections in ... on line 40
    P,BODY{FONT-FAMILY:tahoma,arial,sans-serif;FONT-SIZE:11px;}

    There seems to have been a slight problem with the database.
    Please try again by pressing the refresh button in your browser.
    An E-Mail has been dispatched to our Technical Staff, who you can also contact if the problem persists.
    We apologise for any inconvenience.
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X