Announcement

Collapse
No announcement yet.

SQL error?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SQL error?

    Tonight I got home from dinner and checked my email and had a bunch of the following messages, all sent at the same time:

    Database error in vBulletin :

    Link-ID == false, connect failed
    mysql error: Lost connection to MySQL server during query

    mysql error number: 2013

    Date: Wednesday 05th of March 2003 09:49:01 PM
    Script: /board/
    So I went to check out my board to make sure it was on the up and up and three forums were missing, and all the posts in those forums. Where the forums used to be is this:
    Server shutdown in progress
    What is the problem here and is there anyway to resolve it without having to use my backup (which is a couple weeks old)?

    Thanks for any help.

  • #2
    It looks like MySQL went down and possibly corrputed your database. Try this first. Upload repair.php (it's in the 'extras' folder of the zip file) to your admin directory. Close your forums, then run it from your browser with this syntax:

    http://www.yourdomain.com/forum/admin/repair.php?html=1&check=1

    [Of course change the exact URL as appropriate for your forums.]

    If everything reports 'Ok' then reopen your forums. If not, then run it again. The second time everything should report Ok. See if this fixes the problem.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I tried it as instructed, and everything came back OK the second time, but still the forums are missing and I'm getting the "Server shutdown in progress" where my forums used to be.

      Any other ideas?

      By the way I'm using 2.2.9 and the url is http://www.socaluncensored.com/board/

      Thanks again.

      Comment


      • #4
        Just an update, I can get to my missing forums after running the repair, but they are still missing from the main board page. But for instance http://www.socaluncensored.com/board...php3?forumid=3 will still get me to one of the forumns that is no longer there on /board/

        Steve

        Comment


        • #5
          Fill out a support ticket at:

          http://www.vbulletin.com/members/support_form.php

          Be sure to include the login info to your Admin CP, phpMyAdmin and FTP.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X