Announcement

Collapse
No announcement yet.

SQL Error! Please help!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SQL Error! Please help!

    I just removed a user that had been flooding our site with porn ads. I had found the user by typing "georges" into the email box in the admin. Prior to this, I had found the same user by typing "yummy",

    The user came up with a different email address than any of the hotpop or BonBon email addresses I was looking for, but the same user came up no matter which of the suspicious email names I typed in. That user had no posts, so I removed them.

    Now, when i type the word "georges" or "george" or even "geo" or "ge" into the find users by email address field in the admin, I get the following error:

    Warning: MySQL: Unable to save result set in /home/www/aquariumpros/forums/admin/db_mysql.php on line 93
    P,BODY{FONT-FAMILY:tahoma,arial,sans-serif;FONT-SIZE:11px;}

    There seems to have been a slight problem with the Aquariumpros.com Bulletin Board database.
    Please try again by pressing the refresh button in your browser.
    An E-Mail has been dispatched to our Technical Staff, who you can also contact if the problem persists.
    We apologise for any inconvenience.

    Then in the field below, you see the following message:

    Database error in vBulletin Control Panel 2.2.8:
    Invalid SQL: SELECT user.userid,username,usergroupid,birthday,email,parentemail,coppauser,homepage,icq,aim,yah oo,signature,usertitle,FROM_UNIXTIME(joindate) AS joindate,FROM_UNIXTIME(lastvisit) AS lastvisit,FROM_UNIXTIME(lastpost) AS lastpost,posts,ipaddress,userfield.* FROM user,userfield WHERE 1=1 AND INSTR(LCASE(email),'ge')>0 AND userfield.userid=user.userid ORDER BY username LIMIT 0,300
    mysql error: Got error 134 from table handler
    mysql error number: 1030
    Date: Tuesday 04th of March 2003 03:06:23 PM
    Script: http://www.aquariumpros.com/forums/f...admin/user.php
    Referer: http://www.aquariumpros.com/forums/a...ction=modify&s=


    Can anyone please help?

  • #2
    You can try to run repair.php to fix the database error. It looks like it is corrupt. But .. i am not THAT good with php/mysql so could be wrong. Doesn't hurt to try.

    Comment


    • #3
      OK:

      I ran the repair.php to repair the databse overall, and there is one error set shown in the results:

      Checking table userfieldTableOperationTypeTextvb1.userfieldcheckwarningTable is marked as crashedvb1.userfieldcheckerrorFound 872 keys of 870vb1.userfieldcheckerrorCorruptRepairing table userfieldvb1.userfieldrepairstatusOKOptimizing table userfieldvb1.userfieldoptimizestatusOK



      Help?

      Comment


      • #4
        Is the problem fixed?

        Comment


        • #5
          Nevermind

          Forgot I had phpMyadmin. Just ran a repair there on the userfield table and the problem seem to be fixed.

          Comment


          • #6
            Glad to see it fixed

            Comment


            • #7
              Yes thank you, problem solved. Very glad to have phpMyadmin installed. Just ran repair.php again and the problem is gone.

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X