Announcement

Collapse
No announcement yet.

return-path of mails wrong

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • peterska2
    replied
    Please do not post in threads from 5 years ago and for extremely old versions of vBulletin.

    Leave a comment:


  • sun_tzu
    replied
    Originally posted by feldon23 View Post
    zfrank,

    You rock.
    this is a hack!!!

    once you install an update from vBulletin, this change will be lost.

    Why can't a value be stored in the email options section that allows you to store this value as a part of the code base?

    Leave a comment:


  • feldon23
    replied
    zfrank,

    You rock.

    Leave a comment:


  • zfrank
    replied
    Originally posted by gourou
    could u send me your file modified cause I have the same weird problem with qmail and some mailservers

    but I did not find "return-path" in function.php

    thanx in advance


    jp
    I fixed it so:
    find in admin/function.php this:

    Code:
     $from = trim($from);
     $username = trim($username);
    and add after this:
    Code:
    $headers .= "Return-Path: <[email protected]>\n";
    this is all... and working for me without problems...

    here the code after modifying

    Code:
     $from = trim($from);
     $username = trim($username);
     $headers .= "Return-Path: <[email protected]****.com>\n";

    Leave a comment:


  • gourou
    replied
    anonymous qmail

    Originally posted by zfrank
    Ok
    I searched mail-function in vB and found an solution.
    I hardcoded in admin/function.php Return-Path, now it is working for me.

    could u send me your file modified cause I have the same weird problem with qmail and some mailservers

    but I did not find "return-path" in function.php

    thanx in advance


    jp

    Leave a comment:


  • zfrank
    replied
    Ok
    I searched mail-function in vB and found an solution.
    I hardcoded in admin/function.php Return-Path, now it is working for me.

    Leave a comment:


  • zfrank
    started a topic return-path of mails wrong

    return-path of mails wrong

    I´ve problem. Return-path of forum-mails is wrong.
    It is always set to [email protected]
    Some smtp-server reject this mail with message, don´t accept anonymous mail.
    How can I change this?

    Here an header of a mail:

    Return-Path: <[email protected]>
    Received: from localhost (localhost.localdomain [127.0.0.1])
    by localhost.localdomain (8.12.5/8.12.5) with ESMTP id h1S8hCwb007904
    for <[email protected]>; Fri, 28 Feb 2003 09:43:12 +0100
    Envelope-to: [email protected]
    Delivery-date: Fri, 28 Feb 2003 09:25:28 +0100
    Received: from pop.kundenserver.de [212.227.126.233]
    by localhost with POP3 (fetchmail-5.9.0)
    for [email protected] (single-drop); Fri, 28 Feb 2003 09:43:12 +0100 (CET)
    Received: from [207.44.196.90] (helo=mydomain.com)
    by mxng04.kundenserver.de with smtp (Exim 3.35 #1)
    id 18ofpb-00023m-00
    for [email protected]; Fri, 28 Feb 2003 09:25:23 +0100
    Received: (qmail 8874 invoked by uid 48); 28 Feb 2003 08:27:22 -0000
    Date: 28 Feb 2003 08:27:22 -0000
    Message-ID: <[email protected]>
    To: [email protected]
    Subject: Reply to post 'IRC-Channel #gsm'
    From: "GSM-Forum Mailer" <[email protected]>
    Last edited by zfrank; Sat 16 Aug '03, 11:46pm.
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X