Announcement

Collapse
No announcement yet.

Problem with usergroup/forum permissions

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Steve Machol
    replied
    There is currently no way to add a user group as Moderator. This requires hacking. I don't see an option for this in vB 3 at this time.

    Leave a comment:


  • john_rsd
    replied
    Originally posted by Steve Machol
    Changing this behaviour requires hacking. You can ask over at vbulletin.org.
    Steve

    I undestand Jérémies' confusion over the hierarchy of the group permissions settings and how they are applied.

    I have tried to get around this by denying access to the default Moderator user group by creating my own groups & permissions as I will also have several forums with restricted access except special user groups and would like to apply special moderator privelages to these forums. I can then just add users to any group I wish (?) without individually editing forum permissions. In the php??2 installation I just removed in favour of vB this was real easy to do.

    But I seem unable to apply a user group as a moderator to a particluar forum easily as the moderator feild only accepts a single user name.

    Any way to add a group as modertaor to a particular forum instead of editing user groups by individual forums? Sorry if this is a simple question but sometimes it is harder to understand when you are too used to working in a slightly different ACL structure

    Has any of this been improvements in vB3?

    Leave a comment:


  • Jérémie
    replied
    Originally posted by Steve Machol
    Changing this behaviour requires hacking. You can ask over at vbulletin.org.
    Thanks.
    The simpliest way to do it is here, if anyone has the same problem.

    Leave a comment:


  • Steve Machol
    replied
    Changing this behaviour requires hacking. You can ask over at vbulletin.org.

    Leave a comment:


  • Jérémie
    replied
    Originally posted by Steve Machol
    Moderators have access to all private forums by default. To change this you need to set their forum permissions manually to 'No' for a particular forum.
    By moderator you mean someone who is moderator of any forum on my boards ?
    Manually, you mean user by user ? Argh
    Is there a way to change that ? I suppose there is somewhere in the code a thing that say "put this to on by default" ?

    Leave a comment:


  • Steve Machol
    replied
    Moderators have access to all private forums by default. To change this you need to set their forum permissions manually to 'No' for a particular forum.

    Leave a comment:


  • Jérémie
    started a topic Problem with usergroup/forum permissions

    Problem with usergroup/forum permissions

    Hi

    I have a problem with some permissions (vB 229, user mask active, some change in templates but nothing heavy, no hack or anything just plain install) :

    Ok first I have a usergroup "Modérateurs forums" who has all (but attachment) to "yes" except: super moderator and control panel (both to no).

    I check and put all personnal (user by user) permission to default for all the members of my usergroup "Modérateurs forums"

    Then, i create a forum "Sysops" that is configurated with: no parent, private, no thread rating, allow img code, and all other options by default.

    The members of "Modrateurs forums" still view (and can post) in my sysops forum !
    So I go to forums permissions, I edit the "Sysops/Modérateurs forums" permission, Custum settings: all to No.

    They can still view it ! If I check for personnal Forums Acces for one of the member of "modérateurs forums", they have the "sysops forum" to "yes". I don't know why.

    And that's bother me, soon I will have about a dozen of usergroup with 10 to 30 differents users in them, I can't change the forum permission one user by one user

    Anyone know why this is happening, and what to do ?

    Sorry for misuse of english
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X