Announcement

Collapse
No announcement yet.

PM popup not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PM popup not working

    The IM support - check for new PM's is set to yes in the VB CP. Pop up a box when you receive a Private Message is set to yes for the user. The following is a partial source code of the forums page when the user gets a new PM:
    <script language="JavaScript">
    <!--
    function confirm_newpm() {
    input_box=confirm("You have a new private message. Click OK to view it, or cancel to hide this prompt." );
    if (input_box==true) { // Output when OK is clicked
    second_box=confirm("Open in new window?\n\n(Press cancel to open your Inbox in the current window.)" );
    if (second_box==true) {
    window.open('private.php?s=','pmnew','width=600,height=500,menubar=yes,scrollbars=yes,tool bar=yes,location=yes,directories=yes,resizable=yes,top=50,left=50');
    } else {
    window.location="private.php?s=";
    }
    } else {
    // Output when Cancel is clicked
    }
    }
    // -->
    </script>
    </head>
    <body onload="java script:confirm_newpm()" bgcolor="#003399" text="#000000" id="all" leftmargin="10" topmargin="10" marginwidth="10" marginheight="10" link="#000000" vlink="#000000" alink="#000020">
    Is there something I'm missing? I'm using IE 6 with medium security settings.

    I know this should work since other forums that I visit pop up a window when I get a new pm.
    rstark
    New Member
    Last edited by rstark; Fri 7 Feb '03, 1:48am.

  • #2
    This stops working in IE 6 sometimes when cookies or the cache becomes corrupted. Empty your browser cache and if necessary manually delete your cookies.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Originally posted by Steve Machol
      This stops working in IE 6 sometimes when cookies or the cache becomes corrupted. Empty your browser cache and if necessary manually delete your cookies.
      That's not it. I tried that and used another workstation, and still no luck.

      Comment


      • #4
        If you have not installed any hacks, fill out a support ticket at:

        http://www.vbulletin.com/members/support_form.php

        Be sure to include the login info to your Admin CP and FTP.

        If you have installed hacks, then remove the hacks first before filling out the support request. Make sure to include the login info to the specific account you are having this problem with.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Same Problem

          Does anyone have any clues on this issue. I am having the same problem.

          my site is at http://www.byuboyz.com

          Comment


          • #6
            Had the same issue. It was an easy fix for me. There was a ' missing in the headnewpm code template at the following place: window.open('http
            No hacks installed and no changes had been made. Put in the ' after the ( and works great now. Might just be a fluke but might help others.

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X