Announcement

Collapse
No announcement yet.

Can't login as admin onto admin panel after moving servers...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't login as admin onto admin panel after moving servers...

    hi!

    I've just restored vb database onto a new server and it seems i can't log in onto admin panel to review vars and reflect path changes...

    It keeps displaying the login page and that's all. No password error, nothing.

    I've tried all combinations and triple checked users/passwords for connection to the database.

    How can i check VB settings and alter paths and settings so i can enter as admin?

    I do have phpmyadmin access and telnet/shell access as well.

    PLease advice.

    Thanks!

  • #2
    In phpMyAdmin, run this query:

    SELECT * FROM template WHERE title='options'

    Then find the values for $cookiepath and $cookiedomain and edit them so that they work on your new server, then save the template again.

    You should then be able to log into your control panel. From there, go straight to the vBulletin options and update the Cookie Path and Cookie Domain fields to match the values you put in the options template.

    Comment


    • #3
      Cookiedomain is "" and Cookiepath is "/"

      I don't get it!

      Comment


      • #4
        Can you log in to your admin account in the front-end?

        Comment


        • #5
          No, cuz i shut down the vB before it could accept more posts and alter the dumped DB....

          Shall I "open" it via the sql query above and try? is that safe?

          Comment


          • #6
            Yes, that would work fine... just set $bbactive=1 in the options template.

            Comment


            • #7
              Done.

              I can't still log in. Whenever I fill in the user/pass, i'm taken to the password reminder page AND if I click on any subforum, I get:

              vBulletin MessageNo forum specified. If you followed a valid link, please notify the webmaster

              IdeaS?

              Comment


              • #8
                Upload the phpinfo.php file from the 'extras' directory of the zip file to your forums directory. Then post the URL here.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Can you help me telling me what to find on the list of information?

                  I'd like to avoid sharing this info for the moment....

                  Comment


                  • #10
                    Moreover,

                    Whenever i click on any nick, i'm also lead to the password request form...

                    how come?!

                    I tried to delete cookies on my computer but it did not solve the problem.

                    What else might be failing? Forum description, board stats, members and such information is read correctly.

                    I'm totally lost.

                    Comment


                    • #11
                      It sounds to me like your SQL dump did not complete importing correctly. Try clearing your database and importing your SQL file again, and if this still doesn't work, submit a support ticket via the members' area along with the necessary username and password to access your server and one of our people will do their best to assist you.

                      Comment


                      • #12
                        It actually was not a dump but a mysql/var direct copy, plus later running myisamchk -r -o *.MYI to avoid table corruption.

                        Filecomparing, files appear identical on both servers...

                        Is there any missconfiguration on apache .conf file that would cause something like this?

                        That might be the only difference, aside from the path and new domain itself...

                        Comment


                        • #13
                          Btw,

                          On error log, I can find this:

                          [Mon Jan 27 18:35:26 2003] [error] PHP Warning: (null)() [<a href='http://www.php.net/ref.outcontrol'>ref.outcontrol</a>]: output handler 'ob_gzhandler' cannot be used twice in Unknown on line 0

                          Comment


                          • #14
                            If you don't want to share the info on these forums then the best option is to fill out a support ticket as Kier suggested. To do this go here:

                            http://www.vbulletin.com/members/support_form.php

                            Be sure to include the login info to your Admin CP and FTP.
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment


                            • #15
                              I think i've isolated the problem. The problem is it seems i don't have the mysql php4 module installed. Is there any way i can do this on my own?

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X