Announcement

Collapse
No announcement yet.

Reduce Errors

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Reduce Errors

    Hi Guys,

    When i have about 30 people on my forum i get a load of error messages sent to me via email they say
    Database error in vBulletin :

    Link-ID == false, connect failed
    mysql error: Too many connections

    mysql error number: 1040

    Date: Tuesday 21st of January 2003 09:27:20 AM
    Script: /forums/member.php?s=&action=getinfo&userid=217
    Referer:
    How do i reduce the number of connections to the DB or is it a simple "Change Your Host" Solution?

    Thanks
    Matthew

  • #2
    The server has maxed out the number of MySQL connections it allows. You can try turning persistent connections off in your config.php:

    PHP Code:
    // use persistant connections to the database
    // 0 = don't use
    // 1 = use
    $usepconnect 0
    But if you still have problems after that, all you can do is ask your host
    to raise the maximum number of connections they allow.

    Here is more info on that error:

    http://www.mysql.com/doc/T/o/Too_many_connections.html
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Thanks! I have done it now. Is there any disadvantage to not using persistent connections? Becuase i got onto my host and thay say that i have been allowed up to 500 connections at any time


      But i have changed it to not using them now and just wondered if there would be any differences doing so!

      Thanks a lot
      Matthew

      Comment


      • #4
        I've never noticed any difference with this on or off.

        Also the '500' connections is almost certainly for the whole server. If you are on a shared server, then you are sharing the connections with everyone else on that server.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          OK, Thanks mate! And yes i am on a shared server My forums arent big enough to warent me getting a dedicated just yet

          Thanks for the help.

          Matthew

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X