Announcement

Collapse
No announcement yet.

smilie uploads... permissions?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • smilie uploads... permissions?

    I'm wondering if I need to change permissions for the images file or what? I'm getting this when attempting to upload a smilie:
    Warning: Unable to create '../images/smilies/filename.gif': Permission denied in /home/place/public_html/forums/admin/smilie.php on line 37

    Smilie successfuly uploaded

    Record added
    In the past I always added them to the server first. This is the first time I tried to upload one from my drive.
    what do I need to do to fix this little error?

  • #2
    Does php have permission to write to the smilie directory?
    If not you have to chmod it. 666 should do it.

    Comment


    • #3
      Originally posted by vBR
      Does php have permission to write to the smilie directory?
      If not you have to chmod it. 666 should do it.
      the images folder is at 755...so is the smilies folder. shouldn't that work?
      owner can read write and execute...755 is the default with vB right...for the smilies and the option to upload? I have never changed it.

      Comment


      • #4
        I think php is 'other user' and needs chmod 666 - 766 to write in that directory.

        Comment


        • #5
          Originally posted by vBR
          I think php is 'other user' and needs chmod 666 - 766 to write in that directory.
          I changed the directory: 'smilies' to 666. then I reuploaded and still received the same error also with it at 666, the images in admin for smiles disappeared. weird. I've never read anywhere before that I needed to change permissins if I want to upload smilies this way. I'm confused...
          I just changed the permissions for smilies folder back to 755 so the images show again in admin.
          am I misunderstanding?

          Comment


          • #6
            O.K.
            That's me confused too.

            Anyone else?

            Comment


            • #7
              Originally posted by vBR
              O.K.
              That's me confused too.

              Anyone else?
              maybe the images just disappeared on me because the admin cp got a little weird when I refreshed...
              but all the same...I'm confused too about the permissions.
              Thanks for trying to help me out nontheless
              In the mean time I'll just add them the way I always did before....place them in my smilies dir. on my server and then point to them. no biggie, I'm just curious as to why that options there, but not working correctly.

              Comment


              • #8
                Originally posted by vBR
                O.K.
                That's me confused too.

                Anyone else?
                Folders need to have 'execute' permissions in order to read from them AFAIK.

                Comment


                • #9
                  Originally posted by MUG
                  Folders need to have 'execute' permissions in order to read from them AFAIK.
                  I thought it was:
                  'read' = read from
                  'write' = write to
                  'execute' = run script

                  permissions:
                  0 = No permissions
                  1 = Write only permission
                  2 = Execute only permission
                  3 = Read only permission
                  4 = Write and execute permissions
                  5 = Read and execute permissions
                  6 = Read and write permissions
                  7 = All permissions

                  Groups:
                  Owner
                  Group members
                  Other users


                  So what does php need to do in the smilies folder?
                  There are no scripts to run in there so it does not need execute.
                  To use the smilies in the forums it must be able to read.
                  If you use php to upload new smilies then it has to be able to write too.

                  I believe the default is 755.
                  To let php upload I think you need 766

                  Comment


                  • #10
                    Hmm...
                    Code:
                    [PowerMac-G4:~] alex% mkdir testing
                    [PowerMac-G4:~] alex% chmod 666 testing
                    [PowerMac-G4:~] alex% cd testing
                    testing: Permission denied.

                    Comment


                    • #11
                      Originally posted by MUG
                      Hmm...
                      Code:
                      [PowerMac-G4:~] alex% mkdir testing
                      [PowerMac-G4:~] alex% chmod 666 testing
                      [PowerMac-G4:~] alex% cd testing
                      testing: Permission denied.
                      who cares about 666 anyway...755 is getting permission denied and it is vB's default for smilie directory (I believe)
                      heyyy coool you have a powermac G4!

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X