Announcement

Collapse
No announcement yet.

My vBulletin not sending emails anymore?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • My vBulletin not sending emails anymore?

    Hi,

    I have searched the forums for a solution but found nothing...

    It seems since I upgraded to 2.2.9, my vBulletin has stopped sending any emails, including :
    - membership activation emails (this is a major issue!)
    - notification emails

    Even the "Email Users" in the Admin CP doesn't work. It says "... sending... OK... All done!" but the emails never go through.

    Am I missing something in the setup? These email features have always worked perfectly before. Any hint on what might be wrong?

    Thanks!

  • #2
    Hmmm...there's absolutely nothing in the upgrade scripts that would cause vB to stop sending emails. Are you sure you have the mail option enabled in the Admin CP? Have you checked the server logs to see what's happened to these emails?

    Upload mailtest.php to your forums directory (it's in the 'extras' folder of the zip file) and run it from your browser. Using your email address as a test, what happens? Any errors? Do you get the email?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Well, I tried the mailtest.php and it says "Mail sent. Were any errors shown? If there were, mail is probably not set up correctly." whatever the email address I use (I tried several of mine).

      I remember when I had 2.2.7, some members with AOL addresses never received activation emails, but it was working for all the others, and the notification emails were working too.

      I have been using a shared server at Infinology for almost 2 years and everything has always been perfect. I don't think they have changed anything in their server setup. I am totally clueless on why this is happening now... Any other way to check/know if my server is working/set up correctly?

      Thanks

      PS: Yes the email options are enabled in the Admin CP

      Comment


      • #4
        Since there were no errors, this means it's either a mail server issue or a mailbox issue. You will need to view the mail logs on the server to see what happened to those emails. Once vB sends it to PHP it's in the hands of the server. If you are on a shared server you may need to ask your host to look through the logs for you.

        For what it's worth I get a lot of bounced emails from people who's mail boxes are full, 'unavailable' or over quota. This is a particular problem with hotmail and yahoo accounts. Unless you are on a dedicated server and can set where these bounce messages go, you will never see them. The mail logs will have a record of these though.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X