Announcement

Collapse
No announcement yet.

spooky global PM disabled problem?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • spooky global PM disabled problem?

    three days ago, I upgraded my site from 2.2.8 to 2.2.9 and everything seems fine for a day or so, but then the weirdest thing happened sometime last night? It appears that all users including me, the admin, had their profile options where changed so that their "Enable Private Messaging?" option in the CP turned off?

    and are getting the error message:

    "You have turned off private messages. You may not view or send private messages until you turn them on by editing your profile."

    I ran repair.php and it didn't come up with any errors and it didn't fix the problem.

    Does anyone have an explanation how this could have happened? Weird? Kinda twilight zonish

    If anyone has any suggestions, I'd appreciate it. Thanks

  • #2
    Hmm..do you have any hacks installed? There's nothing in the upgrade process that could have done this.

    To set this back on for everyone, first backup your database then run this query:

    UPDATE user SET receivepm=1;
    Last edited by Wayne Luke; Tue 14 Jan '03, 2:55pm. Reason: Fixed Spelling Error in table name.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Steve,

      Yes, I do have a few hacks installed, but they were up and running fine as well before this happened. Thanks for the tip on fixing the problem. I appreciate it. I really didn't mean to imply that it had anything to do with the update, I was just giving a little background info on my situation Thanks

      Comment


      • #4
        Originally posted by heynurse
        Steve,

        Yes, I do have a few hacks installed, but they were up and running fine as well before this happened. Thanks for the tip on fixing the problem. I appreciate it. I really didn't mean to imply that it had anything to do with the update, I was just giving a little background info on my situation Thanks
        Steve, I tried the query and got the following error:

        Error
        SQL-query:
        UPDATE use SET receivepm=1;

        MySQL said: You have an error in your SQL syntax near 'use SET receivepm=1' at line 1
        ---------------------

        any ideas? I'm not too familiar with running querys. Thanks
        Last edited by heynurse; Tue 14 Jan '03, 5:59pm.

        Comment


        • #5
          That needs to be:

          UPDATE user SET receivepm=1;

          It looks like you entered:

          UPDATE use receivepm=1;
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Originally posted by Steve Machol
            That needs to be:

            UPDATE user SET receivepm=1;

            It looks like you entered:

            UPDATE use receivepm=1;
            Great, that worked great!

            I copied the command from the e-mail notification, and for some reason, that said "use" and not "user"

            Thanks again!

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X