Announcement

Collapse
No announcement yet.

Max Users Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Max Users Problem

    A few times a day I end up getting this message from my site:

    Database error in vBulletin :

    Link-ID == false, connect failed
    mysql error: User [email protected] has already more than 'max_user_connections' active connections

    mysql error number: 1203

    Date: Tuesday 14th of January 2003 03:32:04 PM
    Script: /forums/forumdisplay.php?s=&forumid=42
    Referer: <A href="http://www.discussanything.com/forums/index.php?s=[/quote">http://www.discussanything.com/forums/index.php?s=
    What can I do to fix this?

    Is it a server side solution? A software solution?

    Will trimming the DB work?

    I usually have about 40 users connected when this happens.
    www.discussanything.com

  • #2
    The server has maxed out the number of MySQL connections it allows. You can try turning persistent connections off in your config.php:

    PHP Code:
    // use persistant connections to the database
    // 0 = don't use
    // 1 = use
    $usepconnect 0
    But if you still have problems after that, all you can do is ask your host to raise the maximum number of connections they allow.

    Here is more info on that error:

    http://www.mysql.com/doc/T/o/Too_many_connections.html
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Originally posted by Steve Machol
      The server has maxed out the number of MySQL connections it allows. You can try turning persistent connections off in your config.php:

      PHP Code:
      // use persistant connections to the database
      // 0 = don't use
      // 1 = use
      $usepconnect 0
      But if you still have problems after that, all you can do is ask your host to raise the maximum number of connections they allow.

      Here is more info on that error:

      http://www.mysql.com/doc/T/o/Too_many_connections.html
      What are the ramifications of turning off persistent connections?

      Will the users experience anything differently?
      www.discussanything.com

      Comment


      • #4
        I've never noticed any difference with this off. Users *may* experience slightly longer loading times when browsing your forums. You can try it and if it doesn't work out, change it back.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by Steve Machol
          I've never noticed any difference with this off. Users *may* experience slightly longer loading times when browsing your forums. You can try it and if it doesn't work out, change it back.
          Thanks going to give that a try.

          Do you have any other general suggestions for improving the overal performance of the board?
          www.discussanything.com

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X