Announcement

Collapse
No announcement yet.

Problem adding new avators

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Steve Machol
    replied
    If you are receiving the exact 'same error' then you didn't take care of the open_basedir restrictions correctly.

    Fill out a support ticket at:

    http://www.vbulletin.com/members/support_form.php

    Be sure to include the login info to your Admin CP and FTP.

    Leave a comment:


  • niudlezz
    replied
    I have done that and still receiving the same error. When in the administration page of the forum, under Avators>upload, shouldn't the path to image be "images/avators/" then browse and save changes? The avators directory is already chmodded as well.

    Leave a comment:


  • Steve Machol
    replied
    You have open_basedir restrictions on your server. To get uploads to work you need to create a 'tmp' subdirectory under your httpdocs directory and chmod it to 777. Then in the Admin CP set "Upload In Safe Mode?" to 'Yes' and point the "Safe Mode Temp Directory" to that directory. If you placed the tmp directory in the right place, the path to the Safe Mode Temp Directory will be:

    /home/virtual/site1/fst/tmp

    Leave a comment:


  • niudlezz
    replied
    Sorry for posting a new thread, I lost the url.

    Here is the url for the phpinfo.php: http://www.animefantasia.com/forum/phpinfo.php

    It does say: safe_mode Off Off

    Shouldn't the upload area in the admin upload options be: "/home/virtual/site1/fst/var/www/html/forum/images" ?




    Originally posted by Steve Machol
    Did you follow my instruction and find the location of the upload directory and create and/or chmod this directory to 777?

    Upload the phpinfo.php file from the 'extras' directory of the zip file to your forums directory. Then post the URL here.

    Leave a comment:


  • Steve Machol
    replied
    Originally posted by niudlezz
    Ok, I have tried that and I have contacted my host also. Safe mode is already off since my image gallery needed safe mode off anyways. It is still giving me:

    Warning: open_basedir restriction in effect. File is in wrong directory in /home/virtual/site1/fst/var/www/html/forum/admin/avatar.php on line 39

    avatar successfuly uploaded


    I have chmodded the direct yet it still will not work. Anyone?
    Did you follow my instruction and find the location of the upload directory and create and/or chmod this directory to 777?

    If you don't know what the full path is, go to .../admin/index.php?action=phpinfo and search for "DOCUMENT_ROOT". The value there will be the path on your server yourdomain.com/. You can then set the path to the upload directory based on that.
    Upload the phpinfo.php file from the 'extras' directory of the zip file to your forums directory. Then post the URL here.

    Leave a comment:


  • niudlezz
    replied
    Ok, I have tried that and I have contacted my host also. Safe mode is already off since my image gallery needed safe mode off anyways. It is still giving me:

    Warning: open_basedir restriction in effect. File is in wrong directory in /home/virtual/site1/fst/var/www/html/forum/admin/avatar.php on line 39

    avatar successfuly uploaded


    I have chmodded the direct yet it still will not work. Anyone?

    Leave a comment:


  • Steve Machol
    replied
    Admin CP -> vBulletin Options -> Upload Options

    Leave a comment:


  • niudlezz
    replied
    When you said "then set the "Safe Mode Upload Directory" option in the control panel to point to that directory", where is that located in the forum control panel?

    Leave a comment:


  • Floris
    replied
    Originally posted by Steve Machol
    You need to create a directory, chmod it to 777, and then set the "Safe Mode Upload Directory" option in the control panel to point to that directory. You will need the full directory path to it.

    If you don't know what the full path is, go to .../admin/index.php?action=phpinfo and search for "DOCUMENT_ROOT". The value there will be the path on your server yourdomain.com/. You can then set the path to the upload directory based on that.
    Thank you for the clear instructions, I will try to test them later on and see if I can 'fix' this.

    Leave a comment:


  • Steve Machol
    replied
    You need to create a directory, chmod it to 777, and then set the "Safe Mode Upload Directory" option in the control panel to point to that directory. You will need the full directory path to it.

    If you don't know what the full path is, go to .../admin/index.php?action=phpinfo and search for "DOCUMENT_ROOT". The value there will be the path on your server yourdomain.com/. You can then set the path to the upload directory based on that.

    Leave a comment:


  • niudlezz
    replied
    Argh, sooner or later all php scripts are going to require safe mode to be off.

    Leave a comment:


  • Floris
    replied
    Originally posted by niudlezz
    I am trying to add multiple avators on the forum but every time I do it on the admin, it says "images/avatars could not be found", yet there is a directory for it.

    Also if I was to upload an avator in the admin, after submitting it, it tells me:
    "Warning: open_basedir restriction in effect. File is in wrong directory in /home/virtual/site1/fst/var/www/html/forum/admin/avatar.php on line 39

    avatar successfuly uploaded

    Record added"

    I have chmoded the directory so files could be uploaded yet it still does not work. Any clues?
    Before 2.2.9 I have never had any problems with safe_mode turned on and uploading new images through the admin control panel, but ever since my hosting provider upgraded and updated their software and php and since I have installed 2.2.9, I can't .. the frontend uploads works fine, just not the back-end version. I think this is just due to the safe_mode restricktions.

    Leave a comment:


  • niudlezz
    started a topic Problem adding new avators

    Problem adding new avators

    I am trying to add multiple avators on the forum but every time I do it on the admin, it says "images/avatars could not be found", yet there is a directory for it.

    Also if I was to upload an avator in the admin, after submitting it, it tells me:
    "Warning: open_basedir restriction in effect. File is in wrong directory in /home/virtual/site1/fst/var/www/html/forum/admin/avatar.php on line 39

    avatar successfuly uploaded

    Record added"

    I have chmoded the directory so files could be uploaded yet it still does not work. Any clues?
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X