Announcement

Collapse
No announcement yet.

Server Time Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Server Time Problem

    Hello Ive searched other threads but I cant seem to find an answer to my problem.

    I have been running a forum and the time has been fine. I set the time to GMT -5 (U.S. Eastern) and everything was fine.

    Then a fellow admin told me the time was incorrect.
    So I logged in and sure enough its 9:26 PM and it says 6:47 PM
    So I went to the admin CP changed to a different time zone, changed it back, logged out, then logged in, and it was fixed!

    I then went back a minute later and it said 6 again!

    This has never happened and we have not modified any code for a LONG time - version is 2.2.7 and i tried using a PHP command to echo the server time and its the correct time

    any help please reply

  • #2
    The only way this would happen is if the server time was changing. You need to contact your host about this.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I'm having the exact same problem.

      My vbulletin board is showing the current time is 2:28 AM, my current time setting is at PST which would be 3:28 PM.

      You said the server clock must be off and I should just email my host and ask them to reset their clock?

      Comment


      • #4
        How do you know the server time isn't correct for the timezone it's in? If you are sure about this, then yes, you'll need to contact your host and ask them to fix it.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          I believe the company is east coast which would explain SOME difference, but its 13 hours fast. =)

          I suppose I could try offsetting the clock incorrectly, basically setting it for whatever time zone would give me the correct time. But then it may show the time as some weird time zone, better to just correct it through the server if possible.

          Comment


          • #6
            You'd be better off contacting your host and asking them to check the server time.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              I did both, the board is now set to timbucktoo time or some such.

              It displays the date and time correctly but I will still be contacting our host to see if we can get it straightened out correctly.

              Thank you for the multiple quick responses and good advice. Either way the problem should be resolved.

              By the way, at the bottom it says, "All times are GMT. The time now is 04:18 PM."

              The time is not actually GMT, the time is set to Timbucktoo time. Is it possible to reset this to actually show the time zone its set for?

              I suppose I could change the actual template, but it seems like this is more of a bug than something I should work around.

              Comment


              • #8
                If you to set the timezone in the Admin CP to match the timezone of the server your forums are running on, then the time should display correctly. Of course, each user needs to set their local timezones in the User CP.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Originally posted by Steve Machol
                  If you to set the timezone in the Admin CP to match the timezone of the server your forums are running on, then the time should display correctly. Of course, each user needs to set their local timezones in the User CP.

                  i'm having similar problems
                  i set the timezone at GMT west european, London , Lisbon etc etc

                  and since i live in UK the whole United kingdom has same time period

                  so why am displayed 12.04 am
                  when its 5.04 am

                  so how do i set the time to Match Server in Admin Cp??
                  rugs|cheap rugs|modern rugs|shaggy rugs|traditional rugs

                  Comment


                  • #10
                    See my answer above. This is the correct way to set your time. Note that GMT time will always be displayed to guests and unlogged in users.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Originally posted by Steve Machol
                      See my answer above. This is the correct way to set your time. Note that GMT time will always be displayed to guests and unlogged in users.
                      I set it to GMT London time from admin i'm sure of it
                      so what should i do
                      rugs|cheap rugs|modern rugs|shaggy rugs|traditional rugs

                      Comment


                      • #12
                        You either did not set the timezone in the Admin CP to the timezone of your server, or you did not set your User CP correctly.
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          Originally posted by msimplay
                          I set it to GMT London time from admin i'm sure of it
                          so what should i do

                          LOLLLLLLLLLLLL
                          sorry very sorry indeed
                          i misinterpreted your answer
                          well i realised
                          since my Isp in the US i should set The Admin cp time same as Us time

                          as in not london but GMT -5.00 US & CANADA

                          that finally fixed it it was gonna be a bugger if it didn't else my Announcement times and calender date would be all wrong
                          rugs|cheap rugs|modern rugs|shaggy rugs|traditional rugs

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X