Announcement

Collapse
No announcement yet.

ignore list bug

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ignore list bug

    We are running vB 2.2.8 and have a member registered as MB'ER.
    It is not possible to add MB'ER to the ignore list.
    The following error is generated:

    The user 'MB\'ER' was not found in the database. Please go back and correct this problem. You may want to check out the member list.

    Obviously, the single quote is the problem.
    Does anyone have a fix other than changing the member's name?

  • #2
    Originally posted by wpwood3
    We are running vB 2.2.8 and have a member registered as MB'ER.
    It is not possible to add MB'ER to the ignore list.
    The following error is generated:

    The user 'MB\'ER' was not found in the database. Please go back and correct this problem. You may want to check out the member list.

    Obviously, the single quote is the problem.
    Does anyone have a fix other than changing the member's name?
    Confirmed.

    1. Ran query:
    Code:
    mysql> insert into user (username) values ("Apostro'phe");
    Query OK, 1 row affected (0.01 sec)
    2. Added Apostro'phe to the ignore list.

    3. Got:
    The user 'Apostro\'phe' was not found in the database. Please go back and correct this problem. You may want to check out the member list.
    Unhacked 2.2.9.
    --filburt1, vBulletin.org/vBulletinTemplates.com moderator
    Web Design Forums.net: vB Board of the Month
    vBulletin Mail System (vBMS): webmail for your forum users

    Comment


    • #3
      Originally posted by filburt1
      Confirmed.

      1. Ran query:
      Code:
      mysql> insert into user (username) values ("Apostro'phe");
      Query OK, 1 row affected (0.01 sec)
      2. Added Apostro'phe to the ignore list.

      3. Got:

      Unhacked 2.2.9.
      I tried to reproduce this but I had no luck, the only thing i could think of was that you have magic_quotes_gpc on.
      Scott MacVicar

      My Blog | Twitter

      Comment


      • #4
        Originally posted by Scott MacVicar
        I tried to reproduce this but I had no luck, the only thing i could think of was that you have magic_quotes_gpc on.
        I'm running 4.3.0 with no customizations on Windows 2000, if that helps.
        --filburt1, vBulletin.org/vBulletinTemplates.com moderator
        Web Design Forums.net: vB Board of the Month
        vBulletin Mail System (vBMS): webmail for your forum users

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X