Announcement

Collapse
No announcement yet.

Warning: Unknown Mysql ?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Warning: Unknown Mysql ?

    While installing the vBulletin this waring comes up?
    Any ideas as to remady this problem?

    Warning: Unknown MySQL Server Host 'http' (2) in /home/www/justinternationals/Binder-Bench/admin/db_mysql.php on line 38

    Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in /home/www/justinternationals/Binder-Bench/admin/db_mysql.php on line 47

  • #2
    Originally posted by Eagle-Mark
    While installing the vBulletin this waring comes up?
    Any ideas as to remady this problem?

    Warning: Unknown MySQL Server Host 'http' (2) in /home/www/justinternationals/Binder-Bench/admin/db_mysql.php on line 38

    Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in /home/www/justinternationals/Binder-Bench/admin/db_mysql.php on line 47
    change mysql server back to localhost instead of http
    :: Always Back Up Forum Database + Attachments BEFORE upgrading !
    :: Nginx SPDY SSL - World Flags Demo [video results]
    :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

    Comment


    • #3
      Originally posted by eva2000
      change mysql server back to localhost instead of http
      Thank you!
      That got me to this problem.

      Warning: Failed opening './db_localhost.php' for inclusion (include_path='') in /home/www/justinternationals/Binder-Bench/admin/install.php on line 334

      Fatal error: Cannot instantiate non-existent class: db_sql_vb in /home/www/justinternationals/Binder-Bench/admin/install.php on line 336

      Comment


      • #4
        Originally posted by Eagle-Mark
        Thank you!
        That got me to this problem.

        Warning: Failed opening './db_localhost.php' for inclusion (include_path='') in /home/www/justinternationals/Binder-Bench/admin/install.php on line 334

        Fatal error: Cannot instantiate non-existent class: db_sql_vb in /home/www/justinternationals/Binder-Bench/admin/install.php on line 336
        make sure config.php has

        Code:
        // type of database running
        // (only mysql is supported at the moment)
        $dbservertype="mysql";
        
        // hostname or ip of server
        $servername="localhost";
        :: Always Back Up Forum Database + Attachments BEFORE upgrading !
        :: Nginx SPDY SSL - World Flags Demo [video results]
        :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

        Comment


        • #5
          Originally posted by eva2000
          make sure config.php has
          Code:
           
          // type of database running 
          // (only mysql is supported at the moment) 
          $dbservertype="mysql"; 
           
          // hostname or ip of server 
          $servername="localhost";
          If I change config.php to this:
          // type of database running
          // (only mysql is supported at the moment)
          $dbservertype='mysql';
          // hostname or ip of server
          $servername='localhost';

          I get this:
          Warning: Access denied for user: '[email protected]' (Using password: YES) in /home/www/justinternationals/Binder-Bench/admin/db_mysql.php on line 38

          Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in /home/www/justinternationals/Binder-Bench/admin/db_mysql.php on line 47

          Comment


          • #6
            This error means either:

            1. One or more of the following is wrong in your config.php file:

            $dbusername
            $dbpassword
            $dbname

            If you are unsure of what the appropriate values are then you will need to ask your web host.

            2. Or that this db user is not assigned to that database or does not have permission to access MySQL to create a database. You may need to first manually create the database and assign the db user to it. Since each web host is different, if you do not know how to do this then contact your web host for help.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Originally posted by Steve Machol
              This error means either:

              1. One or more of the following is wrong in your config.php file:

              $dbusername
              $dbpassword
              $dbname

              If you are unsure of what the appropriate values are then you will need to ask your web host.

              2. Or that this db user is not assigned to that database or does not have permission to access MySQL to create a database. You may need to first manually create the database and assign the db user to it. Since each web host is different, if you do not know how to do this then contact your web host for help.
              They asure me my information is correct.
              $dbusername = correct
              $dbpassword = correct
              $dbname = correct

              and I get this message.
              Warning: Access denied for user: '[email protected]' (Using password: YES) in /home/www/justinternationals/Binder-Bench/admin/db_mysql.php on line 38

              Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in /home/www/justinternationals/Binder-Bench/admin/db_mysql.php on line 47

              when I looked on the server there is a config.php and aconfig.php.new?
              Anyway both have the same information.

              I never found any instructions to uplaod any thing from the extra file?

              Comment


              • #8
                Here is the config.php file.
                Password has been changed to correct to hide mine.

                <?php
                /////////////////////////////////////////////////////////////
                // Please note that if you get any errors when connecting, //
                // that you will need to email your host as we cannot tell //
                // you what your specific values are supposed to be //
                /////////////////////////////////////////////////////////////
                // type of database running
                // (only mysql is supported at the moment)
                $dbservertype='mysql';
                // hostname or ip of server
                $servername='localhost';
                // username and password to log onto db server
                $dbusername='justinternationals';
                $dbpassword='correct';
                // name of database
                $dbname='BinderBench';
                // technical email address - any error messages will be emailed here
                $technicalemail='[email protected]';
                // use persistant connections to the database
                // 0 = don't use
                // 1 = use
                $usepconnect=1;
                ?>

                Comment


                • #9
                  Originally posted by Eagle-Mark
                  Here is the config.php file.
                  Password has been changed to correct to hide mine.

                  <?php
                  /////////////////////////////////////////////////////////////
                  // Please note that if you get any errors when connecting, //
                  // that you will need to email your host as we cannot tell //
                  // you what your specific values are supposed to be //
                  /////////////////////////////////////////////////////////////
                  // type of database running
                  // (only mysql is supported at the moment)
                  $dbservertype='mysql';
                  // hostname or ip of server
                  $servername='localhost';
                  // username and password to log onto db server
                  $dbusername='justinternationals';
                  $dbpassword='correct';
                  // name of database
                  $dbname='BinderBench';
                  // technical email address - any error messages will be emailed here
                  $technicalemail='[email protected]';
                  // use persistant connections to the database
                  // 0 = don't use
                  // 1 = use
                  $usepconnect=1;
                  ?>
                  it means your host or you haven't set up the database BinderBench to be accessed by that username/password.... try readding that user/pass to that database
                  :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                  :: Nginx SPDY SSL - World Flags Demo [video results]
                  :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                  Comment


                  • #10
                    Originally posted by eva2000
                    it means your host or you haven't set up the database BinderBench to be accessed by that username/password.... try readding that user/pass to that database
                    I recieved this also via e-mail.


                    Database error in vBulletin Control Panel :

                    Link-ID == false, connect failed
                    mysql error: Access denied for user: '[email protected]' (Using password: YES)

                    mysql error number: 1045

                    Date: Wednesday 18th of December 2002 06:37:06 PM
                    Script: /Binder-Bench/admin/
                    Referer:

                    Comment


                    • #11
                      My original response still stands, as does eva's reiteration of it. If the variables in #1 are correct, then the problem is #2.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        Thanks all!
                        I am in.
                        The problem was the length of my username. It is the same as the user name for the web site but in MySQL the username is limited to 16 letters and or numbers...
                        This is after my server instructed my to use the full 19

                        Your help was great!

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X