Announcement

Collapse
No announcement yet.

E-mail not being sent out.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • E-mail not being sent out.

    Hi,

    I transferred the boards from one server to another, and all went well, except that now, mail is not being sent to people who have subbed to threads, to me when there's a new user, when people request PM notifications. When I update a thread I'm subbed to, the following error appears:

    Warning: Server Error in D:\Project\YoohooDummy\hoonation\boards\newreply.php on line 203
    Warning: Server Error in D:\Project\YoohooDummy\hoonation\boards\newreply.php on line 328

    Any thoughts?



  • #2
    Upload mailtest.php to your forums directory (it's in the 'extras' folder of the zip file) and run it from your browser. Using your email address as a test, what happens? Any rrors? Do you get the email?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Originally posted by Steve Machol
      Upload mailtest.php to your forums directory (it's in the 'extras' folder of the zip file) and run it from your browser. Using your email address as a test, what happens? Any rrors? Do you get the email?
      On the mailtest.php page itself, I get:

      Notice: Undefined variable: address in D:\Project\YoohooDummy\hoonation\boards\mailtest.php on line 7

      And when the mail is sent, I get: Warning: Server Error in D:\Project\YoohooDummy\hoonation\boards\mailtest.php on line 17

      Comment


      • #4
        This would seem to be a server problem. Are you on a dedicated or shared server?

        Upload the phpinfo.php file from the 'extras' directory of the zip file to your forums directory. Then post the URL here.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by Steve Machol
          This would seem to be a server problem. Are you on a dedicated or shared server?

          Upload the phpinfo.php file from the 'extras' directory of the zip file to your forums directory. Then post the URL here.
          It's a dedicated server.

          http://www.drinkyoo-hoo.com/hoonatio...ds/phpinfo.php

          Comment


          • #6
            The SMTP setting in php.ini is set to 'smtp.comstar.net'. Where is this server?

            Try editing php.ini to:

            SMTP = localhost

            Then restart your web server.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Originally posted by Steve Machol
              The SMTP setting in php.ini is set to 'smtp.comstar.net'. Where is this server?

              Try editing php.ini to:

              SMTP = localhost

              Then restart your web server.
              I still get Warning: Server Error in D:\Project\YoohooDummy\hoonation\boards\newreply.php on line 328

              and

              Warning: Failed to Connect in D:Project\YoohooDummy\hoonation\boards\private.php on line 618


              Comment


              • #8
                Do you actually have a SMTP server running on your server? For some reason the PHP mail() function is not working. I'd suggest contacting your host and asking them for help.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Thanks for your help - I've contacted them.

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X