Announcement

Collapse
No announcement yet.

too many connections + server load

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    You probably still need to increase the max_connections:

    http://www.vbulletin.com/forum/showt...threadid=41678
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #17
      Originally posted by Male_LadyBug
      the same problem is there

      1040 errors are filling my email up :S

      and server loads are still high?
      i checked in your server from the log in info you submitted to support ticket system and it appears one of your sites' log files in your /usr/local/apache/domlogs directory has hit linux's 2GB file limit, you need to remove that log or ask your host to setup log rotation so it doesn't reach linux's 2GB file limit... now i see why this is causing you to swap to disk by enormous amounts!
      :: Always Back Up Forum Database + Attachments BEFORE upgrading !
      :: Nginx SPDY SSL - World Flags Demo [video results]
      :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

      Comment


      • #18
        Where do you get it?

        Where does all this mysqlinfo.php file stuff come from, the output would be really helpful, but I can't find it in the vB download? Where do I get it?

        Comment


        • #19
          Originally posted by mark99
          Where does all this mysqlinfo.php file stuff come from, the output would be really helpful, but I can't find it in the vB download? Where do I get it?
          It's in the 'extras' folder.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #20
            i did all that
            but sometime over 30 ( very high server load ) !!
            and i get this message Tcp Error now !
            Good times are for friends to share

            Comment


            • #21
              What's the complete error message?
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #22
                Originally posted by Male_LadyBug
                i did all that
                but sometime over 30 ( very high server load ) !!
                and i get this message Tcp Error now !
                did you read my reply

                i checked in your server from the log in info you submitted to support ticket system and it appears one of your sites' log files in your /usr/local/apache/domlogs directory has hit linux's 2GB file limit, you need to remove that log or ask your host to setup log rotation so it doesn't reach linux's 2GB file limit... now i see why this is causing you to swap to disk by enormous amounts!
                :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                :: Nginx SPDY SSL - World Flags Demo [video results]
                :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                Comment


                • #23
                  Originally posted by eva2000
                  did you read my reply

                  i checked in your server from the log in info you submitted to support ticket system and it appears one of your sites' log files in your /usr/local/apache/domlogs directory has hit linux's 2GB file limit, you need to remove that log or ask your host to setup log rotation so it doesn't reach linux's 2GB file limit... now i see why this is causing you to swap to disk by enormous amounts!
                  yess ....
                  Good times are for friends to share

                  Comment


                  • #24
                    Originally posted by Male_LadyBug
                    yess ....
                    yes you read the reply, or yes following my instructions you fixed your problem ?
                    :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                    :: Nginx SPDY SSL - World Flags Demo [video results]
                    :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                    Comment


                    • #25
                      Originally posted by eva2000
                      yes you read the reply, or yes following my instructions you fixed your problem ?
                      yes i followed your instructions

                      i always do
                      Good times are for friends to share

                      Comment


                      • #26
                        Sat Dec 21 01:32:30 EST 2002


                        1:32am up 4 days, 2:59, 0 users, load average: 31.38 , 19.89, 9.75
                        286 processes: 283 sleeping, 1 running, 1 zombie, 1 stopped
                        CPU0 states: 18.0% user, 29.0% system, 0.0% nice, 51.1% idle
                        CPU1 states: 12.1% user, 2.0% system, 0.0% nice, 84.1% idle
                        Mem: 1030984K av, 1005172K used , 25812K free, 0K shrd, 3896K buff
                        Swap: 1052248K av, 914876K used , 137372K free 130028K cached

                        PID USER PRI NI SIZE RSS SHARE STAT %CPU %MEM TIME COMMAND
                        15201 nobody 17 0 1176 1176 820 R 26.6 0.1 0:00 top
                        15137 nobody 15 0 4460 4048 3192 D 0.0 0.3 0:00 httpd


                        Http processes currently running = 107
                        Mysql processes currently running = 136

                        Netstat information summary
                        1 LAST_ACK
                        3 CLOSE_WAIT
                        3 FIN_WAIT1
                        3 FIN_WAIT2
                        5 SYN_RECV
                        6 CLOSING
                        31 LISTEN
                        55 ESTABLISHED
                        294 TIME_WAIT


                        +---------------------------+-----------------+
                        | Variable_name | Value |
                        +---------------------------+-----------------+
                        | Aborted_clients | 1562 |
                        | Aborted_connects | 130 |
                        | Bytes_received | 4109954539 |
                        | Bytes_sent | 1933871921 |
                        | Com_admin_commands | 0 |
                        | Com_alter_table | 0 |
                        | Com_analyze | 0 |
                        | Com_backup_table | 0 |
                        | Com_begin | 0 |
                        | Com_change_db | 2738184 |
                        | Com_change_master | 0 |
                        | Com_check | 0 |
                        | Com_commit | 0 |
                        | Com_create_db | 0 |
                        | Com_create_function | 0 |
                        | Com_create_index | 0 |
                        | Com_create_table | 0 |
                        | Com_delete | 174199 |
                        | Com_drop_db | 0 |
                        | Com_drop_function | 0 |
                        | Com_drop_index | 0 |
                        | Com_drop_table | 0 |
                        | Com_flush | 0 |
                        | Com_grant | 0 |
                        | Com_insert | 930322 |
                        | Com_insert_select | 4741 |
                        | Com_kill | 0 |
                        | Com_load | 0 |
                        | Com_load_master_table | 0 |
                        | Com_lock_tables | 0 |
                        | Com_optimize | 0 |
                        | Com_purge | 0 |
                        | Com_rename_table | 0 |
                        | Com_repair | 0 |
                        | Com_replace | 5190 |
                        | Com_replace_select | 421 |
                        | Com_reset | 0 |
                        | Com_restore_table | 0 |
                        | Com_revoke | 0 |
                        | Com_rollback | 10478 |
                        | Com_select | 27542669 |
                        | Com_set_option | 0 |
                        | Com_show_binlogs | 0 |
                        | Com_show_create | 0 |
                        | Com_show_databases | 20 |
                        | Com_show_fields | 2 |
                        | Com_show_grants | 0 |
                        | Com_show_keys | 0 |
                        | Com_show_logs | 0 |
                        | Com_show_master_status | 0 |
                        | Com_show_open_tables | 0 |
                        | Com_show_processlist | 1188 |
                        | Com_show_slave_status | 0 |
                        | Com_show_status | 14 |
                        | Com_show_innodb_status | 0 |
                        | Com_show_tables | 7 |
                        | Com_show_variables | 36 |
                        | Com_slave_start | 0 |
                        | Com_slave_stop | 0 |
                        | Com_truncate | 0 |
                        | Com_unlock_tables | 0 |
                        | Com_update | 1472467 |
                        | Connections | 2347013 |
                        | Created_tmp_disk_tables | 338 |
                        | Created_tmp_tables | 211526 |
                        | Created_tmp_files | 0 |
                        | Delayed_insert_threads | 0 |
                        | Delayed_writes | 0 |
                        | Delayed_errors | 0 |
                        | Flush_commands | 1 |
                        | Handler_delete | 154226 |
                        | Handler_read_first | 775716 |
                        | Handler_read_key | 111295383 |
                        | Handler_read_next | 608948446 |
                        | Handler_read_prev | 1889038 |
                        | Handler_read_rnd | 136528249 |
                        | Handler_read_rnd_next | 2428060652 |
                        | Handler_update | 8361309 |
                        | Handler_write | 24770894 |
                        | Key_blocks_used | 15582 |
                        | Key_read_requests | 464154427 |
                        | Key_reads | 960950 |
                        | Key_write_requests | 2369678 |
                        | Key_writes | 2200386 |
                        | Max_used_connections | 193 |
                        | Not_flushed_key_blocks | 0 |
                        | Not_flushed_delayed_rows | 0 |
                        | Open_tables | 1024 | 100% of table_cache in use
                        | Open_files | 1064 |
                        | Open_streams | 0 |
                        | Opened_tables | 6593 |
                        | Questions | 35225598 |
                        | Select_full_join | 863157 |
                        | Select_full_range_join | 0 |
                        | Select_range | 1771120 |
                        | Select_range_check | 0 |
                        | Select_scan | 5107679 |
                        | Slave_running | OFF |
                        | Slave_open_temp_tables | 0 |
                        | Slow_launch_threads | 45 |
                        | Slow_queries | 7439 | (execution time > 10 secs)
                        | Sort_merge_passes | 0 |
                        | Sort_range | 1724338 |
                        | Sort_rows | 138485701 |
                        | Sort_scan | 1228704 |
                        | Table_locks_immediate | 33014790 |
                        | Table_locks_waited | 110732 |
                        | Threads_cached | 122 |
                        | Threads_created | 1814 |
                        | Threads_connected | 8 |
                        | Threads_running | 1 |
                        | Uptime | 356272 | 4 days 2 hrs 57 mins 52 secs
                        +---------------------------+-----------------+


                        Key Reads/Key Read Requests = 0.002070 (Cache hit = 99.99793% )
                        Key Writes/Key Write Requests = 0.928559
                        Connections/second = 6.588 (/hour = 23715.719)
                        KB received/second = 5.886 (/hour = 21190.954)
                        KB sent/second = 5.301 (/hour = 19083.076)
                        Temporary Tables Created/second = 0.594 (/hour = 2137.394)
                        Opened Tables/second = 0.019 (/hour = 66.620)
                        Slow Queries/second = 0.021 (/hour = 75.168)
                        % of slow queries = 0.021%
                        Queries/second = 98.873 (/hour = 355941.957)
                        Good times are for friends to share

                        Comment


                        • #27
                          and now !!


                          6:25am up 4 days, 7:52, 0 users, load average: 50.77 , 20.50, 10.56
                          395 processes: 393 sleeping, 1 running, 0 zombie, 1 stopped
                          CPU0 states: 9.0% user, 22.2% system, 0.0% nice, 67.2% idle
                          CPU1 states: 8.2% user, 6.1% system, 0.0% nice, 84.0% idle
                          Mem: 1030984K av, 1021376K used, 9608K free, 0K shrd, 1540K buff
                          Swap: 1052248K av, 1051256K used, 992K free 55064K cached
                          Good times are for friends to share

                          Comment


                          • #28
                            something is definitely filling up your swap file causing high cpu loads

                            it could also be your slow IDE hard drive consuming more cpu resources...

                            any other apps on your server which use mysql ?
                            Last edited by George L; Sat 21st Dec '02, 5:51pm.
                            :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                            :: Nginx SPDY SSL - World Flags Demo [video results]
                            :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                            Comment


                            • #29
                              Originally posted by eva2000
                              something is definitely filling up your swap file causing high cpu loads

                              it could also be your slow IDE hard drive consuming more cpu resources...

                              any other apps on your server which use mysql ?
                              yes i have three php nukes up but even when i close all three nukes ai still get the problem

                              it seems to be from the vb and starts off when numbers of people online reachs 250 or 260??

                              and would this be causing the problem
                              "| Open_tables | 1024 | 100% of table_cache in use"

                              or do i have to increase the max_connection which is set to 550 right now??
                              Good times are for friends to share

                              Comment


                              • #30
                                Originally posted by Male_LadyBug
                                yes i have three php nukes up but even when i close all three nukes ai still get the problem

                                it seems to be from the vb and starts off when numbers of people online reachs 250 or 260??

                                and would this be causing the problem
                                "| Open_tables | 1024 | 100% of table_cache in use"

                                or do i have to increase the max_connection which is set to 550 right now??
                                tried turning off all other mysql using apps and leave vB running, and next time you get high cpu loads, look at your mysql processlist in phpmyadmin or via the command

                                mysqladmin -u root -p processlist

                                and see what's causing the cpu load
                                :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                                :: Nginx SPDY SSL - World Flags Demo [video results]
                                :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X