Announcement

Collapse
No announcement yet.

too many connections + server load

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • too many connections + server load

    deticated server with dual p111 1ghz
    1 gb ram
    40 gb disk
    T3 connection

    was running vb very smooothly for the last 4 weeks
    vb 2.2.8

    nothing been changed except for average number of vistors to the board

    now i keep getting tons of this message in my email

    Database error in vBulletin :

    Link-ID == false, connect failed
    mysql error: Too many connections

    mysql error number: 1040

    Date: Wednesday 11th of December 2002 02:53:28 PM
    Script:
    /vb/showthread.php?amp;threadid=18848&perpage=15&pagenumber=2


    this is the mysqlinfo file

    http://www.hawaaworld.com/vb/admin/mysqlinfo.php

    http://www.hawaaworld.com/vb/admin/phpinfo.php


    please help

    i changed max connection in my.cnf from 500 to 1000 .... this is the only line in it by the way

    another thing associated with the max conn. problem is server load reaching 4.5 while it was 0.07 in normal state

    thanx
    Good times are for friends to share

  • #2
    Please read http://www.vbulletin.com/forum/showt...threadid=41678

    Comment


    • #3
      Originally posted by Cary
      Please read http://www.vbulletin.com/forum/showt...threadid=41678
      i did so alread set it to 0
      Good times are for friends to share

      Comment


      • #4
        Your mysqlinfo seems to indicate that the Max_used_connections of '100' was reached. Did you change the correct my.cnf file and restart MySQL after making the change?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by Steve Machol
          Your mysqlinfo seems to indicate that the Max_used_connections of '100' was reached. Did you change the correct my.cnf file and restart MySQL after making the change?
          did so
          still high server load
          Good times are for friends to share

          Comment


          • #6
            Originally posted by Male_LadyBug
            did so
            still high server load
            I didn't expect this to change the server load - only the:

            mysql error: Too many connections
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Originally posted by Male_LadyBug
              did so
              still high server load
              from http://www.hawaaworld.com/vb/admin/mysqlinfo.php your table cache is set at 64 try increasing to 1024 and restarting mysql as your swapping to disk right now

              i'd reboot the server to clear the swap usage value in top reported in http://www.hawaaworld.com/vb/admin/mysqlinfo.php so you get a clear idea of how your doing with new settings
              :: Always Back Up Forum Database + Attachments BEFORE upgrading !
              :: Nginx SPDY SSL - World Flags Demo [video results]
              :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

              Comment


              • #8
                Originally posted by eva2000
                from http://www.hawaaworld.com/vb/admin/mysqlinfo.php your table cache is set at 64 try increasing to 1024 and restarting mysql as your swapping to disk right now

                i'd reboot the server to clear the swap usage value in top reported in http://www.hawaaworld.com/vb/admin/mysqlinfo.php so you get a clear idea of how your doing with new settings
                where would i change the table cache from?

                my.cnf only has one line
                the max connection line??
                Good times are for friends to share

                Comment


                • #9
                  Originally posted by Male_LadyBug
                  where would i change the table cache from?

                  my.cnf only has one line
                  the max connection line??
                  in that case try this my.cnf on for size

                  [mysqld]
                  set-variable = max_connections=550
                  set-variable = key_buffer=16M
                  set-variable = myisam_sort_buffer_size=64M
                  set-variable = join_buffer=1M
                  set-variable = record_buffer=1M
                  set-variable = sort_buffer=2M
                  set-variable = table_cache=1024
                  set-variable = thread_cache_size=128
                  set-variable = wait_timeout=14400
                  set-variable = connect_timeout=10
                  set-variable = max_allowed_packet=16M
                  set-variable = max_connect_errors=10

                  [safe_mysqld]
                  open_files_limit=8192

                  [mysqldump]
                  quick
                  set-variable = max_allowed_packet=16M

                  [myisamchk]
                  set-variable = key_buffer=64M
                  set-variable = sort_buffer=64M
                  set-variable = read_buffer=16M
                  set-variable = write_buffer=16M
                  remember to reboot your server to clear the disk swap usage reported in top stats
                  :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                  :: Nginx SPDY SSL - World Flags Demo [video results]
                  :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                  Comment


                  • #10
                    Originally posted by eva2000
                    in that case try this my.cnf on for size

                    remember to reboot your server to clear the disk swap usage reported in top stats
                    thanx
                    i did all the changes and restarted the server

                    load now is 1.09?? :S
                    Good times are for friends to share

                    Comment


                    • #11
                      Originally posted by Male_LadyBug
                      thanx
                      i did all the changes and restarted the server

                      load now is 1.09?? :S
                      inadequate table_cache size was your problem causing mysql to swap to disk = high cpu loads
                      :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                      :: Nginx SPDY SSL - World Flags Demo [video results]
                      :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                      Comment


                      • #12
                        the same problem is there

                        1040 errors are filling my email up :S

                        and server loads are still high?
                        Good times are for friends to share

                        Comment


                        • #13
                          Originally posted by Male_LadyBug
                          the same problem is there

                          1040 errors are filling my email up :S

                          and server loads are still high?
                          bump?
                          Good times are for friends to share

                          Comment


                          • #14
                            If you're referring to the 'Too many connections' error then you'll bneed to increase the max_connections variable again.
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment


                            • #15
                              Originally posted by Steve Machol
                              If you're referring to the 'Too many connections' error then you'll bneed to increase the max_connections variable again.
                              i get this message in my mail now:

                              Database error in vBulletin :

                              Link-ID == false, connect failed
                              mysql error:

                              mysql error number:

                              Date: Sunday 15th of December 2002 01:50:44 PM
                              Script: /vb/showthread.php?amp;threadid=58697
                              Good times are for friends to share

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X