Announcement

Collapse
No announcement yet.

Admin CP - templates not showing!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Admin CP - templates not showing!

    I am in the middle of switching servers. Everything went smooth (I think) and everything seems normal for my visitors - but I have a admin cp problem. When I expand all the templates, I can only access the custom made ones, and the edited. I can see the links for "[change original]", but the link only leads to the "editor", which is blank. Its' obvious that the variables isn't working in template.php.... Here's an example of a link:
    template.php?s=&action=add&templatesetid=1&title=&group= No variables except for the temlatesetid=1....

    Everything worked perfectly on my old host! Ideas?

  • #2
    You are running an older version of vB. This problem is caused by the latest versions of PHP which have broken some of the functions of older versions of vB. Your new host must be running PHP 4.2.x. To fix this you need to upgrade to vB 2.2.9
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I *knew* you would answer that! And I *know* you've heard this zillions of times - I can't! I have used vBulletin as a basis for a templatedriven web page.

      Are there no fixes? Shortcuts? I have discovered that I am able to edit the default templates, if I fill in the templatename - like this:

      template.php?s=&templatesetid=1&action=add&title=<<<< The chosen templatename here >>>>

      I understand that you can not offer custom coding. But I thought it was worth a shot to ask if you know a simple solution.

      Comment


      • #4
        If running 2.2.5 you might be able to get by by uploading the patched files in freddie's post here:

        http://www.vbulletin.com/forum/showt...threadid=44820

        This won't fix all the problems with PHP 4.2.x, but it should fix that one.

        If you are not running 2.2.5, then the only option is to upgrade. Sorry.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Or rewrite template.php - which is what seems like the only solution for me. Kind of hard to upgrade when most php files and MySQL tables are edited.

          Thank you for answering me this quick anyway

          Comment


          • #6
            Originally posted by netphreak
            Kind of hard to upgrade when most php files and MySQL tables are edited.
            Its not hard at all, just download a program like Beyond Compare or Araxis Merge to see the change between the two
            vBulletin.org Moderator
            The Sisters Three Charmed Discussion Forums

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X