Announcement

Collapse
No announcement yet.

too many connections

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • too many connections

    Database error in vBulletin :

    Link-ID == false, connect failed
    mysql error: Too many connections

    mysql error number: 1040

    Date: Sunday 24th of November 2002 05:53:36 AM
    Script:
    /vb/showthread.php?amp;threadid=46028&perpage=15&pagenumber=5
    Referer:
    Good times are for friends to share

  • #2
    .. and your question is?

    Just in case you want this to be fixed, here is a little
    explanation:
    The MySQL server settings are configured to allow a certain max. amount of connections to the database. Unfortn. when this number is reached, it will return an error.

    How to solve that?
    Since this is not a bug or error from vBulletin, but MySQL - the best to do is to contact your hosting provider and ask them to set max_connections limit higher.
    The only thing you can do for vBulletin is alter the option for using persistent connections (disable it) in admin/config.php

    More information:
    http://www.mysql.com/doc/T/o/Too_many_connections.html


    I hope it helps.
    Last edited by Floris; Sun 24th Nov '02, 8:55am.

    Comment


    • #3
      The server has maxed out the number of MySQL connections it allows. You can try turning persistent connections off in your config.php:

      PHP Code:
      // use persistant connections to the database
      // 0 = don't use
      // 1 = use
      $usepconnect 0
      But if you still have problems after that, all you can do is ask your host to raise the maximum number of connections they allow.

      Here is more info on that error:

      http://www.mysql.com/doc/T/o/Too_many_connections.html
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X