Announcement

Collapse
No announcement yet.

Can't upgrade from 2.2.8 > 2.2.9

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't upgrade from 2.2.8 > 2.2.9

    I moved a forum over to a new server, the forum was a 2.2.8. I installed it first as a 2.2.8 and then when I try to upgrade it I get this error

    Parse error: parse error in /home/www/supplementcentral/forums/admin/upgrade22.php(96) : eval()'d code on line 171

    I run the script anyways and it just totally destroys the look of my forum, meaning none of the tables are lining up, colors are all wacky and so forth. I don't have any hacks installed. Any clues, thx.

    OMG, this vb3 kicks arse, it made the text bold for me!
    joor.com | rcfiles.com
    VBB: 3.8.1 | PHP: 5.1.6 | MySQL: 5.0.45
    Host: ThePlanet Dedicated Xeon 3210

  • #2
    When you moved the forum over to the new server, was it working there as 2.2.8 ? Both the backend as the frontend?

    Comment


    • #3
      It was, but it had a problem. It was not showing the templates, it would just say change original and I couldn't update user info from within the admin. Now when I moved the backend from that server to the new one, I can see all the templates so I didn't suspect anything. Could this be it? If so, is there a way to save this forum? The company I am doing this for wants to keep all the posts and users obviously. Maybe I should try a clean install of the 2.2.8 and then try to see it will upgrade? This would show that something in the sql that I am loading from the old site is causing the problem. What do you think?
      joor.com | rcfiles.com
      VBB: 3.8.1 | PHP: 5.1.6 | MySQL: 5.0.45
      Host: ThePlanet Dedicated Xeon 3210

      Comment


      • #4
        Originally posted by Kode
        It was, but it had a problem. It was not showing the templates, it would just say change original and I couldn't update user info from within the admin. Now when I moved the backend from that server to the new one, I can see all the templates so I didn't suspect anything. Could this be it? If so, is there a way to save this forum? The company I am doing this for wants to keep all the posts and users obviously. Maybe I should try a clean install of the 2.2.8 and then try to see it will upgrade? This would show that something in the sql that I am loading from the old site is causing the problem. What do you think?
        As long as you have the 'working' 2.2.8 installed files and .sql backup, you can always just test on the new server.

        The reason why it wasn't showing the templates on the old server was maybe because of PHP version running there.

        Comment


        • #5
          Well it isn't the database. I just installed a fresh copy of 2.2.8, and then uploaded all the 2.2.9 files and run upgrade22.php and get the same exact error. I didn't import anything, just installed the upgrade. So it is either code (which I doubt since others are upgrading fine) or something with the server. Anyone have any clues?

          LOL, here is what it makes my forum look like if I go ahead and run the script anyways. Please remember, this is a fresh install, so I didn't change any colors or anything. I have no idea where these colors came from, haha. Man, this page won't take my upload, so here you go.

          Last edited by Kode; Sat 23 Nov '02, 2:10pm.
          joor.com | rcfiles.com
          VBB: 3.8.1 | PHP: 5.1.6 | MySQL: 5.0.45
          Host: ThePlanet Dedicated Xeon 3210

          Comment


          • #6
            Originally posted by Kode
            Well it isn't the database. I just installed a fresh copy of 2.2.8, and then uploaded all the 2.2.9 files and run upgrade22.php and get the same exact error. I didn't import anything, just installed the upgrade.
            What do you mean by 'fresh install'? If this was truly a fresh install then there would be no reason to run the upgrade script.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              I did a fresh install of 2.2.8 to test out my possible errors. A fresh install of 2.2.9 works fine but I am testing to see if it may be the sql dump that I was importing into the database as the cause for the 2.2.9 upgrade not to work. The test has proven that the error is causes no matter what.

              Either way it doesn't actually matter. The key here is that I did a clean install of 2.2.8, then uploaded 2.2.9 files on top of the 2.2.8 files, run upgrade22.php, and that is when I get the error.
              joor.com | rcfiles.com
              VBB: 3.8.1 | PHP: 5.1.6 | MySQL: 5.0.45
              Host: ThePlanet Dedicated Xeon 3210

              Comment


              • #8
                Sorry I still don't understand why you ran the upgrade script on a fresh install. Did you rerstore the 2.2.8 database first?
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Originally posted by Steve Machol
                  Sorry I still don't understand why you ran the upgrade script on a fresh install. Did you rerstore the 2.2.8 database first?
                  Ok, here is what he means (if I read it right).

                  He moved his board (2.2.8) to a new server, tried to run the upgrade to 2.2.9, and got the above parse error. He then wanted to see is it was SQL that was giving him the error, so he did a fresh install of 2.2.8 and tried to run the upgrade script to 2.2.9 on it.

                  Comment


                  • #10
                    Originally posted by squall14716
                    Ok, here is what he means (if I read it right).

                    He moved his board (2.2.8) to a new server, tried to run the upgrade to 2.2.9, and got the above parse error. He then wanted to see is it was SQL that was giving him the error, so he did a fresh install of 2.2.8 and tried to run the upgrade script to 2.2.9 on it.
                    Yes I know, but did he restore the database after the 'fresh install'? That's what I'm trying to find out. If he didn't restore the database then running the upgrade script was not only unnecessary, it could actually harm the database.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Originally posted by Steve Machol
                      What do you mean by 'fresh install'? If this was truly a fresh install then there would be no reason to run the upgrade script.
                      Hehe!

                      So true ...
                      Is it true that "Cannibals" don't eat Clowns because they taste funny? :eek:

                      Comment


                      • #12
                        Sorry it took me so long to get back, I never received an email until now that there were more posts.

                        The reason I don't just install 2.2.9 is because the sqldump that I have is from 2.2.8. I have now installed it 2 different ways with the same error.

                        First Install:
                        1. Upload 2.2.8 Files (config.php configured)
                        2. placed the sqldump into the database (this was a 2.2.8 dump)
                        3. Viewed forum (perfect 2.2.8 running, my category and posts)
                        4. Upload 2.2.9 files
                        5. Run upgrade22.php (get the error)
                        6. View forum (completely destroyed)

                        Second Install: Dropped all tables in DB
                        1. Upload 2.2.8 Files (config.php configured)
                        2. Ran install.php
                        3. Viewed forum (perfect 2.2.8 running, fresh install)
                        4. Upload 2.2.9 files
                        5. Run upgrade22.php (get the error)
                        6. View forum (completely destroyed)

                        Both ways I get the error, even if I don't use my dump.

                        Third Install: Dropped all tables in DB
                        1. Upload 2.2.9 Files (config.php configured)
                        2. Ran install.php
                        3. Viewed forum (perfect 2.2.9 running, fresh install)

                        Plain install of 2.2.9 works fine.
                        joor.com | rcfiles.com
                        VBB: 3.8.1 | PHP: 5.1.6 | MySQL: 5.0.45
                        Host: ThePlanet Dedicated Xeon 3210

                        Comment


                        • #13
                          Did you download a fresh 2.2.9 zip file and upload the files again? By the looks of your last post it appears you have a bad upgrade22.php file.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            That may very well be it. I will try and grab a new version, especially since it is out of RC and post the results here.
                            joor.com | rcfiles.com
                            VBB: 3.8.1 | PHP: 5.1.6 | MySQL: 5.0.45
                            Host: ThePlanet Dedicated Xeon 3210

                            Comment


                            • #15
                              Great call Steve, you hit it on the head. A new download of 2.2.9 and it was perfect. Still can't believe you called it either. Thank you for the great tip.
                              joor.com | rcfiles.com
                              VBB: 3.8.1 | PHP: 5.1.6 | MySQL: 5.0.45
                              Host: ThePlanet Dedicated Xeon 3210

                              Comment

                              Loading...
                              Working...
                              X