Announcement

Collapse
No announcement yet.

Warning: Too many connections!!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Warning: Too many connections!!

    Guys recently we had a message displayed on the forum:
    "The server is too busy, try later.."

    anyway, we moved our forum into a private ded. server.
    We set NIX* to zero becuas ethe server doesn't allow access to it.

    but we noticed another problem, sometime we get the error message:

    Warning: Too many connections in /home/httpd/vhosts/mydomain/httpdocs/forum/index.php on line 17

    Warning: MySQL Connection Failed: Too many connections in /home/httpd/vhosts/mydomain/httpdocs/forum/index.php on line 17
    Can't open connection to MySQL

    What shall I do to avoid this problem?

  • #2
    read http://www.mysql.com/doc/T/o/Too_many_connections.html

    if you have your own dedicated servers you can increase the max_connections limit via settings you place or alter in a /etc/my.cnf file on your server.
    :: Always Back Up Forum Database + Attachments BEFORE upgrading !
    :: Nginx SPDY SSL - World Flags Demo [video results]
    :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

    Comment


    • #3
      well, the initial problem is some hackers trying to hack the forum or the domain somehow. But if this is also the reason for "Too many connections", even if I increast the number of connections I would have the same problem... is that right?

      Please clarify

      Comment


      • #4
        Your error message:

        server busy, please try again later



        I've recently been receiving complaints about this error and another one: 502 connection hangup. I've thought it was an ISP problem...routers or something?
        Fan Club member for VBulletin Dev and Support Team ;)

        Hysterectomy - GirlsGetGoing.com - Fabulous Fifty

        I'm frequently asked about the skin designer for my forums. ForumSkin.com

        Comment


        • #5
          Originally posted by HAK
          well, the initial problem is some hackers trying to hack the forum or the domain somehow. But if this is also the reason for "Too many connections", even if I increast the number of connections I would have the same problem... is that right?

          Please clarify
          It depends. If there are more connections then is allowed under the increase, then yes. If not, then no.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Just curious,

            how many sql connections would you expect vBulletin to use?

            Seem to be getting this quite often lately myself, and the board is the *only* application accessing the MySQL server and its hitting the max_connection of 100

            Comment


            • #7
              This depends entirely on the number of users you have at any given time.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Max i've ever seen simultaneous is 27

                Its a small community, total registered users is about 100 - mainly euro and US based.

                Its not really a hassle for me to get mysql restarted with more available connections though

                Extra info :

                Tried this with both persistent and non-persistent connections - and have user masks and search functionality turned off.
                Last edited by Praxin; Mon 18 Nov '02, 7:16am.

                Comment


                • #9
                  You can try turning persistent connections off in your config.php:

                  PHP Code:
                  // use persistant connections to the database
                  // 0 = don't use
                  // 1 = use
                  $usepconnect 0
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Heh, see edit above - you beat me to it

                    Comment


                    • #11
                      There is absolutely no reason to get that error if you only have 27 users accessing the database and the configuration allows for 100. Is this a dedicated server?
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X