Announcement

Collapse
No announcement yet.

Attachments - uploaded file is not a valid GIF or JPG file?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Attachments - uploaded file is not a valid GIF or JPG file?

    Hello,

    I have licensed version of vB (2.2.6) -- I'm having a problem with attachments. I only want to allow them in one private forum, I have everything set up correctly, but I always get this message when I try to upload:

    The uploaded file is not a valid GIF or JPG file. Please ensure that it is and try again.
    This only happens when I try to upload .gif or .jpg -- other files work (like .txt and .bmp) I'm a big vB/php/sql dummy and didn't even install the vB onto my server myself. I can't locate the phpinfo.php file on my server. Here is my board though.

    Any help is much appreciated. Thanks

    ~Nicole

  • #2
    Could you upload phpinfo.php to your server? (it's found in the 'extras' folder of your vBulletin zip file)

    After you do that, please post the URL to it here.

    Comment


    • #3
      Please excuse my lack of vB skills -- I can't find the .zip file -- I didn't install the board - - I paid for installation..

      Comment


      • #4
        Ok, since that was the case, I looked through the database and found your FTP details and uploaded phpinfo.php for you.

        http://www.nsyncstudio.com/mb/phpinfo.php

        It looks like your server is running in Safe Mode. You need to enable safe mode in the Admin CP and set the Safe Mode 'temp directory' to a directory that is chmoded to 777. Use the full path to that directory on the server.

        Comment


        • #5
          Alright, I changed it to run in safe mode, I made a folder on my server call "tmp" -- but how do I

          set the Safe Mode 'temp directory' to a directory that is chmoded to 777. Use the full path to that directory on the server.
          Thanks again for all your help

          ~Nicole

          Comment


          • #6
            Do you know how to chmod stuff? If you FTP client (program) look for something that says 'Set Attributes' 'Set Permissions' or something like that. cmod it to 777

            After you do that, under 'Safe Mode Temp Directory' set the full path to the directory you created. (i.e. /home/http_docs/uploads)

            Comment


            • #7
              I sucessfully changed the directory to 777 in WS_FTP:

              SITE chmod 777 tmp
              200 CHMOD successful.


              But for Safe Mode Temp Directory, should I put:

              http://www.nsyncstudio.com/mb/tmp

              or

              /mb/tmp

              ?

              Comment


              • #8
                Neither. You need to find the exact path to this directory and use that. It'll probably be something like this:

                /home/nsynchstudio/mb/tmp
                or
                /home/nsynchstudio/tmp
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Thank you so much! It works 100% perfectly!

                  Have a great day!

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X