Announcement

Collapse
No announcement yet.

Attachments not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Attachments not working

    I've moved my forum to a new server and upgaded it to v2.2.8.

    Now my attachments aren't working. When you try to upload an attachment, it doesn't show up.

    Forum: http://www.railroadforums.com/forum/

    Php info file: http://www.railroadforums.com/forum/phpinfo.php


    (Yes, I just asked this question a couple of days ago. I have 3 licenses, and I'm moving all 3. That one worked, but this one isn't...)

  • #2
    You have open_basedir restrictions on your server. To get uploads to work you need to create a 'tmp' subdirectory under your httpdocs directory and chmod it to 777. Then in the Admin CP set "UploadIn Safe Mode?" to 'Yes' and point the "Safe Mode Temp Directory" to that directory. If you placed the tmp directory in the right place, the path to the Safe Mode Temp Directory will be:

    /home/httpd/vhosts/railroadforums.com/httpdocs/tmp
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      First off, thanks for the quick response...

      Unfortunately, that didn't fix the problem. The odd thing is that I have another forum on the same server (but different virtual site) that didn't need any modifications to accept uploads...

      In any case, I've created the tmp directory and chmod'd it to 777. I then updated the settings and it still won't let me upload.

      Now what?

      Comment


      • #4
        Never mind! Operator error...

        I've got one topic in the whole forum where I moderate posts. It's the special announcements topic, and guess where I chose to try and post an image to test image posting?

        Well, the "moderate image" function works exactly as advertised, and that's why they weren't showing up. I didn't recall even selecting that option.

        So, sorry to bother you and thanks for the very prompt response, on a weekend no less.

        Comment


        • #5
          Originally posted by RHarbison
          So, sorry to bother you and thanks for the very prompt response, on a weekend no less.
          No problem. And I generally work 7 days a week. My last full day off was September 13th.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment

          Loading...
          Working...
          X