Announcement

Collapse
No announcement yet.

mysql error number: 1064 ?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • mysql error number: 1064 ?

    I got an email this morning from my board:

    Database error in vBulletin 2.2.8:

    Invalid SQL: DELETE FROM searchindex WHERE wordid IN (0) AND postid=
    mysql error: You have an error in your SQL syntax near '' at line 1

    mysql error number: 1064


    Like my ID says, I'm a Novice here. I have idea how to fix this, or even if I need to fix this ?

  • #2
    Is that the complete error message?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Here is the entire email:

      From: [email protected]
      Date: Thu Oct 24, 2002 09:01:23 AM US/Pacific
      To: [email protected]
      Subject: vBulletin (forum) Database error!

      Database error in vBulletin 2.2.8:

      Invalid SQL: DELETE FROM searchindex WHERE wordid IN (0) AND postid=
      mysql error: You have an error in your SQL syntax near '' at line 1

      mysql error number: 1064

      Date: Thursday 24th of October 2002 10:01:21 AM
      Script: http://mydomain.com/forum/forum/editpost.php
      Referer: http://mydomain.com/orum/editpost.ph...ost&postid=881

      Comment


      • #4
        Thanks. Try this first. Reupload the original editpost.php from the zip file. Make sure you upload in ASCII and overwrite the one on the server.

        Now try to edit one of your posts. If you still get this error, then upload repair.php (it's in the 'extras' folder of the zip file) to your admin directory. Close your forums, then run it from your browser with this syntax:

        http://www.yourdomain.com/forum/admin/repair.php?html=1&check=1

        [Of course change the exact URL as appropriate for your forums.]

        If everything reports 'Ok' then reopen your forums. If not, then run it again. The second time everything should report Ok. See if this fixes the problem.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Thanks Steve, I'll give it a try.

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X