Announcement

Collapse
No announcement yet.

Logged in as wrong user.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Update:


    After talking some time with one of the users having the problem here are some things to look into.


    User A is registered for over a year and has "remember username and password" set to yes and "browse boards with cookies" set to yes as well.

    User B (coppa user who isnt verified an cant even post) has "remember username and password" set to yes and "browse board with cookies" set to no.



    ANY help would be appreciated. We have 40K+ members and I'm having too many users report this as a problem. I would surely consider this a bulletin board crisis.
    Tony Rieker | Founder of PBNation.com - one of the LARGEST vBulletin forums on the net!

    Comment


    • #17
      You have more users reporting this problem? The only way I know of for this to happen is if your users are accessing your forums from behind the same proxy IP and they are using sessionhash instead of cookies to browse the forums.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #18
        The problem stopped. *shrug*

        The only things that were done to remedy the situation were to downgrade mmcache and empty the session table. Which one solved the problem I don't know.


        There were probably half a dozen users that had reported this as a problem.
        Tony Rieker | Founder of PBNation.com - one of the LARGEST vBulletin forums on the net!

        Comment


        • #19
          Most likely it was the session table. However once they start accessing again from behind the same proxy IP, the problem will reappear. To fix this you need to set these account to use cookies instead of sessionhash.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #20
            I am having this problem again. People who are logging in as other users are not behind the same proxy.
            Tony Rieker | Founder of PBNation.com - one of the LARGEST vBulletin forums on the net!

            Comment


            • #21
              I honestly do not know of any way this could happen. All I can suggest is to make absolutley sure these account are using cookies:

              - Automatically login when you return to the site? (uses cookies)
              - Browse the board with cookies

              Generally setting these both to 'Yes' should fix the problem.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #22
                Not sure if this applies to anyone's situation, but PHP4.3.3RC1 was causing all sorts of undesired behavior. It's been implicated in user impersonation problems. It's also under suspicion for excrutiatingly slow load times for some people (it was relatively okay from my perspective, but still slow).

                Comment


                • #23
                  Same problem happened to my forum also.

                  When member "A" visit forum it shows other username like "B" on index page but when click some link such as Control panel or PM, it gets back to normal. Funny thing is, they (member A and B) are not even in a same country. Both of them turn on "Automatically login when you return to the site? (uses cookies) & Browse the board with cookies"

                  Any ideas?

                  Comment


                  • #24
                    Originally posted by Steve Machol
                    I honestly do not know of any way this could happen. All I can suggest is to make absolutley sure these account are using cookies:

                    - Automatically login when you return to the site? (uses cookies)
                    - Browse the board with cookies

                    Generally setting these both to 'Yes' should fix the problem.
                    There was one more thing you told me to do the last time I asked this question in another thread...

                    Something abuot Forcing the page to re-load? or similar in control panel. But this will take longer time to load a page as it calls for new/fresh page from the server everytime the page is refreshed.

                    After selecting this mode/option, the cross over never happen to my forums anymore.

                    I think this is the one, Steve do you recall? --> Add No-cache headers
                    Selecting yes will cause vBulletin to add no-cache HTTP headers. These are very effective, so adding them may cause server load to increase due to increase page requests.

                    Comment


                    • #25
                      Yes, that can come into affect when two or more users are using the same ISP and the ISP caches web pages.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #26
                        Originally posted by Steve Machol
                        Yes, that can come into affect when two or more users are using the same ISP and the ISP caches web pages.
                        Is there any solution for this problem?

                        Comment


                        • #27
                          Only the ones I've already posted above.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #28
                            i found the thread... finally... the same thing is happening to me too...

                            i'll try the Header thing and see if it workz... cuz ppl are logged in as other users (myself included) all of a sudden...

                            Originally posted by Steve Machol
                            Only the ones I've already posted above.

                            Comment


                            • #29
                              I've just encountered the same problem (v.2.8.2): One user ("A") suddenly found out, after he had posted, that he was logged in as a different user ("B")...

                              User A is on a Danish ISP, user B on a Spanish - so it's not an ISP cache problem.

                              Both users had cookie browsing on, while user A had Auto-login off.

                              Comment


                              • #30
                                To my knowledge I do not see any way for this to happen. Sorry.
                                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                                Steve Machol Photography


                                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X