Announcement

Collapse
No announcement yet.

Major Cookie Problem Discussion

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Major Cookie Problem Discussion

    this seems to be a grey area.

    what is the problem that takes place once you play with the cookie domain? you must know what it is?

    Why does it cause our forums to go haywire for certain people?

    Can it be fixed?
    Do you see a fix coming for these problems in the future?

    Is there temporary fixes?

  • #2
    the problem is that the cookies that they will have set are for another domain, so if you change your setting it wont change their cookie and they will manually have to remove them.

    The cookie domain is stored locally on the users computer.
    Scott MacVicar

    My Blog | Twitter

    Comment


    • #3
      I am kicking myself over and over again for switching it. I switched it back to the original setting and still problems.

      All this was done while the board was off, i changed it and changed it back before opening the board,

      has the damage been done? cause some users are complaining they are getting logged out no matter what they do.

      Comment


      • #4
        try the new sessions.php file that i posted in the sticky and set the cookie domain to blank and the cookie path to / which are the default settings.
        Scott MacVicar

        My Blog | Twitter

        Comment


        • #5
          here is what i did.

          I shutdown the board because I wanted to switch my forums from
          url.com/forums to its own subdomain, forums.url.com

          I read somewhere on here the cookie url has to be changed so i set it to forums.wpgrevscene.com, I couldnt get the subdomain to work so i scrapped that idea and decided to stay with the url.com/forums.

          I switched everything i changed back to normal, I then had the problem where i couldnt get into the admin, it would just give me a login screen in both frames. so I fixed that by editing the database and changed the cookie url manually.

          then after making sure everything was back to normal i opened the board and users are having problems no. Even I do. I cleared ALL my cookies out, and even delete them ALL manually and I have my user working correctly except for searching the daily posts. it always asks for a username and password.

          what does this mean

          Comment


          • #6
            Will this screw up the users that currently have no problems?

            Originally posted by PPN
            try the new sessions.php file that i posted in the sticky and set the cookie domain to blank and the cookie path to / which are the default settings.

            Comment


            • #7
              can you open a support ticket at http://www.vbulletin.com/members/support.php

              include brief description of problem, ftp username / password, admin username / password and phpmyadmin details and I'll have a look at it.
              Scott MacVicar

              My Blog | Twitter

              Comment


              • #8
                I sent in the ticket, but how do i change my email, i no longer have access to my old email address. so i wont get your reply.

                is this done through the members area?

                Comment


                • #9
                  fixed

                  just tell me what email to change it to and i will do so.
                  Scott MacVicar

                  My Blog | Twitter

                  Comment


                  • #10
                    [email protected]

                    when you say fixed do you mean you fixed the problem.

                    so easily? I guess thats why they pay you the big bucks.

                    Comment


                    • #11
                      changed your email and yes fixed the problem

                      you had the full url as the cookie domain where it should just have been the domain, i changed this to .wpgrevscene.com which will allow you to change to the new sub without any cookie problems and left the cookie path as /

                      Scott MacVicar

                      My Blog | Twitter

                      Comment


                      • #12
                        Awsome! thank you thank you.. I was getting worried there that i really buggered it up. I guess i know now what not to touch.

                        here is something i still have a problem with but it could be unrelated, but just started as well.

                        I just decided to allow guest access, so that is setup fine and dandy.

                        I made sure i cleared out all cookies and started a new browser session.

                        Everything seems to work fine posting, pming, everything except the getdaily posts search.php?action=getdaily

                        When ever i do this it asks me to login. it also creats a guest session with my ip searching the forum, which i do no allow guests to do.

                        weird. by the way this was happening before your fix so it is not related to your fix.

                        Comment


                        • #13
                          you have can search set to no in the user permissions for users that are not logged in.
                          Scott MacVicar

                          My Blog | Twitter

                          Comment


                          • #14
                            yes users that are not logged in cannot seach, But i was logged in and when i went to search it asks me to login.

                            Comment


                            • #15
                              you've removed s=$session[sesssionhash] from the template make sure its

                              search.php?s=$session[sesssionhash]&action=getdaily
                              Scott MacVicar

                              My Blog | Twitter

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X