Announcement

Collapse
No announcement yet.

Error? - "max user connections" - What does this mean?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error? - "max user connections" - What does this mean?

    I cannot access my board...what does the following error mean?


    Warning: User [email protected] has already more than 'max_user_connections' active connections in /home/soulcys1/public_html/admin/db_mysql.php on line 40

    Warning: MySQL Connection Failed: User [email protected] has already more than 'max_user_connections' active connections in /home/soulcys1/public_html/admin/db_mysql.php on line 40



    There seems to have been a slight problem with the database.
    Please try again by pressing the refresh button in your browser.

  • #2
    This means your forum has more connections that your host allows you to have. If this is happening a lot you'll need to ask your host to raise the number of connections they aloow.

    One thing you can try is turning persistent connections off in your config.php:

    PHP Code:
    // use persistant connections to the database
    // 0 = don't use
    // 1 = use
    $usepconnect 0
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Each server has a set maximum number of database connections it can make. Shared servers set it at 45, or it can be up to 100 or more. Your site has become so busy that is has exceeded this maximum. If you are on a dedicated server, you can increase the maximum in your php.ini. If you are on a shared server, your host can do it. Bear in mind that on a shared server all sites on the same server share the number of database connections, and it may that another site on the same server is using up all the db connections. You can also reduce the number of connections by editing your config.php file in the admin directory and setting persistent connections to "0".
      Avatar Chat

      Comment


      • #4
        Thank you!

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X