Announcement

Collapse
No announcement yet.

Avatar Upload problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Avatar Upload problem

    hi all. recently i had to move my forums across servers, andi thought the whole thing went well, with no bugs.

    Today though, a new member was trying to upload an avatar but it wouldn't work. i tried through the adminCP and got this error back:

    Warning: open_basedir restriction in effect. File is in wrong directory in /usr/local/psa/home/vhosts/clan-gir.net/httpdocs/forums/admin/avatar.php on line 39


    i guess it has something to do with permissions, but as to what to do, i am flummuxed.

    Any ideas?

    thanks in advance,

    G4cE

  • #2
    You have open_basedir restrictions on your new server. To get uploads to work you need to create a 'tmp' subdirectory under your httpdocs directory and chmod it to 777. Then in the Admin CP set "Upload In Safe Mode?" to 'Yes' and point the "Safe Mode Temp Directory" to that directory. If you placed the tmp directory in the right place, the path to the Safe Mode Temp Directory will be:

    /usr/local/psa/home/vhosts/clan-gir.net/httpdocs/tmp
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Thanks a lot for avery swift reply that completely fixed my problem. My new member and myself are both very happy, thanks a lot

      Rob Smith

      Comment


      • #4
        No problem!
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Hi, I have a similar problem but I don't beleive it is permissioning as I have already tried the safe mode. When I try to upload an avatar in the Admin CP, I don't get any errors but the files does not get uploaded either. When I try to upload an avatar in my User CP, I get the following error:

          There has been an error in the upload. Please ensure that the file has been correctly selected and that the upload has taken place successfully.

          Any ideas what could be causing this? We recently upgraded to 2.2.8. This is on a dedicated server not a virtual hosting.

          TIA.

          Comment


          • #6
            Mike20001, please post a new thread rather than piggybacking off of this one. Be sure to include a link to your phpinfo.php file.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Sorry Steve...

              Will start a new thread.

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X