Announcement

Collapse
No announcement yet.

Hacker?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hacker?

    For the past few days there have been a few guests, who all have the same IP except for the last 3 numbers, and they (or he) have been viewing private forums. I don't know how either, but I tried logging out myself so that I was a guest, and I got permission denied. Anyone know whats up with this?

  • #2
    It's possible that it's a bot. (i.e. for a search engine)

    What's the IP address? Do you have it recorded?

    Comment


    • #3
      216.239.46.XX

      Comment


      • #4
        It's more than likely a search engine... seeing that it's the same IP with just the last 3 digits changed

        Comment


        • #5
          But why is it able to view private forums?

          Comment


          • #6
            They can't. Even though it says it, they are really viewing the "you do not have access to this page" page.

            Comment


            • #7
              One last question, how are they able to even find my forums on a search engine if I didn't submit it?

              Comment


              • #8
                Originally posted by GaleForce
                One last question, how are they able to even find my forums on a search engine if I didn't submit it?
                Google sometimes follows links and then indexes that one (I'm pretty sure someone is linking to you).

                Comment


                • #9
                  If you look in your profile, you have a link to your site. If a search engine spiders the vbulletin.com site it could look in your profile, find the link to your site and start spidering there.

                  Comment


                  • #10
                    If it wasn't a bot, it could just be somebody guessing forumids (I've done that here to spot a way around security checkpoints in vB). Either way, as Cary said, they're not viewing the forum contents, merely the show_nopermission() page.
                    --filburt1, vBulletin.org/vBulletinTemplates.com moderator
                    Web Design Forums.net: vB Board of the Month
                    vBulletin Mail System (vBMS): webmail for your forum users

                    Comment


                    • #11
                      I logged out and entered a direct link to one of the private forum and I could view it. Is this a cookie not cleared or a security flaw? The VB version is 2.2.5, I also just sent the link to a friend and he is not even signed up at the forums and he could access it too. Obviously he is a trusted person and won't use it, but he has no cookies what so ever to do with the forum.
                      Last edited by olie; Mon 7 Oct '02, 2:01am.

                      Comment


                      • #12
                        Originally posted by olie
                        I logged out and entered a direct link to one of the private forum and I could view it. Is this a cookie not cleared or a security flaw? The VB version is 2.2.5, I also just sent the link to a friend and he is not even signed up at the forums and he could access it too. Obviously he is a trusted person and won't use it, but he has no cookies what so ever to do with the forum.
                        Go to your Admin CP, go to the "Forums & Moderators" section, and click on Permissions, and then set up so that unregistered members cannot access the private forums. Do this for all subforums as well that are private.
                        Avatar Chat

                        Comment


                        • #13
                          I looked at it and the category had not been done. So I changed it, closed all IE windows, deleted all cookies and it still happens?? If I copy this: http://www.mywebsite.com/forums/foru...hp?&forumid=XX(Whatever Private forum I want)

                          I can still view threads. What am I missing here? The top category for the private forums and all the private forums have all "not logged in" "registered" etc users all set to NO in the permissions and I selected the "custom settings" radio button as well and they are now highlighted red.

                          Was this a know issue in 2.2.5?

                          Comment


                          • #14
                            Did you edit custom permissions for the category or (as you should have) each individual forum? There's a bug where forum permissions aren't fully inherited to child forums.
                            --filburt1, vBulletin.org/vBulletinTemplates.com moderator
                            Web Design Forums.net: vB Board of the Month
                            vBulletin Mail System (vBMS): webmail for your forum users

                            Comment


                            • #15
                              Yes each individual forum as well as the category permissions have been edited, checked and double checked!

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X