Announcement

Collapse
No announcement yet.

Database and other errors

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Database and other errors

    In the last week things have started going wrong on my boards.
    Firstly I'm getting 3 or 4 database error email messages a day, and board members are having problems including-
    "I keep getting a message that the administrator has requested that you can only post every 60 seconds or something like that.I waited 4 minutes and it still wouldn't let me post? Then it erased what I had wrote"
    "I can log on and see that I have, let's say, 20 new posts to read. Before I get them read, they suddenly are marked as having been read and they no longer show up on the "View New Posts"
    "Also, at the bottom of the first screen where it shows you who is on, several times in the past couple of days, this has come up and listed me as the only person logged on when just a minute or two before it showed a bunch of other people. Refreshing the screen will bring them back."
    People have also reported that posts within a thread are not displayed in chronological order.

    Some of the database errors-
    "Database error in vBulletin 2.2.4:
    Invalid SQL: SELECT sessionhash,userid,host,useragent,styleid FROM session WHERE lastactivity>1033489925 AND sessionhash='5127cdc20a3bb6a1af2211640580ad51' AND host='198.26.119.85' AND useragent='Mozilla/4.73 [en]C-CCK-MCD (WinNT; U)'
    mysql error: Lost connection to MySQL server during query
    mysql error number: 2013"

    "Link-ID == false, connect failed
    mysql error: Lost connection to MySQL server during query
    mysql error number: 2013"

    "Invalid SQL: UPDATE LOW_PRIORITY thread SET views=views+1 WHERE threadid='7628'
    mysql error: Lost connection to MySQL server during query
    mysql error number: 2013"


    I'm with Venturesonline and submitted a help ticket to them and they said there are no database problems that they're aware of.

    Boards at - www.wdisneyw.com/forums/
    VBulletin version 2.24.
    PHP Version 4.1.2
    Active Persistent Links 0
    Active Links 1
    Client API version 3.23.39
    MYSQL_MODULE_TYPE builtin
    Apache Version Apache/1.3.23

    Thanks in advance

    Joanne

  • #2
    See this post for all the possible causes of a lost connection error:

    http://www.vbulletin.com/forum/showt...265#post310265
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Just checked that post, and it might as well be written in Japanese, as I haven't got the first idea about MySQL or anything related.
      Are you saying it's a problem with my server, and the host could fix it?

      Thanks
      Joanne

      Comment


      • #4
        Originally posted by joanne862
        Are you saying it's a problem with my server, and the host could fix it?
        Yes, it's most likely a server issue. Contact VO again and ask them to look into this a little closer. They are usually very good about these things.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          is this a VO shared or dedicated server ?

          can you post your /etc/my.cnf contents
          :: Always Back Up Forum Database + Attachments BEFORE upgrading !
          :: Nginx SPDY SSL - World Flags Demo [video results]
          :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

          Comment


          • #6
            It's the V650 semi-dedicated.
            Traffic on the boards hasn't increased, so don't know what's suddenly started the problems.

            Sorry, don't know what /etc/my.cnf is. As I said, I don't know the first thing about MySQL. Had to get paid installation for the boards, that's why I haven't upgraded yet, waiting for v3 then I can pay to get it upgraded.

            I'll get back to VO, but if anyone can offer any suggestions in the meantime...

            Thanks

            Joanne
            Last edited by joanne862; Tue 1 Oct '02, 11:43am.

            Comment


            • #7
              Venturesonline increase the database connections from 100 to 150.
              This didn't fix the problem, so they advised me to upgrade to version 2.2.8, which I now have done.
              Since doing this I haven't received any database error message emails, but there are still a couple of problems on the boards-
              The posts within threads aren't being displayed in chronological order.
              New posts aren't showing as being new.
              Who's online doesn't always show up who is online, sometimes shows no one when there are people there.

              Could these still be database-related problems, or are they caused by something else? Need to know whether to get back onto VO or if it's a problem i could solve.

              Thanks
              Joanne

              Comment


              • #8
                Originally posted by joanne862
                Venturesonline increase the database connections from 100 to 150.
                This didn't fix the problem, so they advised me to upgrade to version 2.2.8, which I now have done.
                Since doing this I haven't received any database error message emails, but there are still a couple of problems on the boards-
                The posts within threads aren't being displayed in chronological order.
                New posts aren't showing as being new.
                Who's online doesn't always show up who is online, sometimes shows no one when there are people there.

                Could these still be database-related problems, or are they caused by something else? Need to know whether to get back onto VO or if it's a problem i could solve.

                Thanks
                Joanne
                it's due to the configuration of mysql server settings along with mysql usage on the server

                can you ssh telnet into your V650 a/c ?
                :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                :: Nginx SPDY SSL - World Flags Demo [video results]
                :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                Comment


                • #9
                  Yes, I can SSH into the server (although I've not a clue about SSH commands, need simple instructions )

                  Also had another database error email today.

                  Thanks
                  Joanne

                  Comment


                  • #10
                    ssh in and type

                    Code:
                    mysqladmin -u mysqlusername -p variables
                    then copy and paste out here

                    then type

                    Code:
                    mysqladmin -u mysqlusername -p extended-status
                    then copy and paste out here
                    :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                    :: Nginx SPDY SSL - World Flags Demo [video results]
                    :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                    Comment


                    • #11
                      delayed_insert_limit | 100 delayed_insert_timeout | 300 delayed_queue_size | 1000 | flush | OFF | flush_time | 0 | have_bdb | NO | have_gemini | NO | have_innodb | NO | have_isam | YES | have_raid | NO
                      | have_openssl | NO | init_file | interactive_timeout | 28800 | join_buffer_size | 4190208 | key_buffer_size | 33550336 | language | /usr/share/mysql/english/ | large_files_support | ON | locked_in_memory | OFF | log | OFF | log_update | OFF | log_bin | OFF | log_slave_updates | OFF | log_long_queries | OFF | long_query_time | 10
                      | low_priority_updates | OFF | lower_case_table_names | 0 | max_allowed_packet | 8387584
                      | max_binlog_cache_size | 4294967295 || max_binlog_size | 1073741824 | max_connections | 1000 | max_connect_errors | 10
                      | max_delayed_threads | 20 | max_heap_table_size | 16777216 |
                      | max_join_size | 4294967295 | max_sort_length | 1024 | max_user_connections | 150 | max_tmp_tables | 32 | max_write_lock_count | 4294967295 | myisam_max_extra_sort_file_size | 256
                      | myisam_max_sort_file_size | 2047
                      | myisam_recover_options | 0 | myisam_sort_buffer_size | 8388608 | net_buffer_length | 16384
                      | net_read_timeout | 30 | net_retry_count | 10 | net_write_timeout | 60 | open_files_limit | 0 | pid_file | /var/lib/mysql/lake.vosn.net.pid |
                      | port | 3306 | protocol_version | 10 | record_buffer | 4190208
                      | record_rnd_buffer | 4190208 | query_buffer_size | 0 | safe_show_database | OFF | server_id | 0 | slave_net_timeout | 3600
                      | skip_locking | ON
                      | skip_networking | OFF
                      | skip_show_database | OFF | slow_launch_time | 2
                      | socket | /var/lib/mysql/mysql.sock | sort_buffer | 6291448
                      | sql_mode | 0 | table_cache | 1024
                      | table_type | MYISAM
                      | thread_cache_size | 128 | thread_stack | 65536
                      | transaction_isolation | READ-COMMITTED | timezone | MDT | tmp_table_size | 33554432 | tmpdir | /tmp/ | version | 3.23.45 | wait_timeout | 600 -----------

                      Variable_name | Value |
                      +--------------------------+----------+
                      | Aborted_clients | 0 |
                      | Aborted_connects | 1 |
                      | Bytes_received | 3285229 |
                      | Bytes_sent | 51709608 |
                      | Connections | 1150 |
                      | Created_tmp_disk_tables | 90 |
                      | Created_tmp_tables | 714 |
                      | Created_tmp_files | 0 |
                      | Delayed_insert_threads | 0 |
                      | Delayed_writes | 0 |
                      | Delayed_errors | 0 |
                      | Flush_commands | 1 |
                      | Handler_delete | 41 |
                      | Handler_read_first | 601 |
                      | Handler_read_key | 132549 |
                      | Handler_read_next | 1336323 |
                      | Handler_read_prev | 203 |
                      | Handler_read_rnd | 555015 |
                      | Handler_read_rnd_next | 14266468 |
                      | Handler_update | 1462 |
                      | Handler_write | 39948 |
                      | Key_blocks_used | 5936 |
                      | Key_read_requests | 662201 |
                      | Key_reads | 5805 |
                      | Key_write_requests | 7271 |
                      | Key_writes | 434 |
                      | Max_used_connections | 5 |
                      | Not_flushed_key_blocks | 0 |
                      | Not_flushed_delayed_rows | 0 |
                      | Open_tables | 367 |
                      | Open_files | 695 |
                      | Open_streams | 0 |
                      | Opened_tables | 380 |
                      | Questions | 22058 |
                      | Select_full_join | 12 |
                      | Select_full_range_join | 0 |
                      | Select_range | 3391 |
                      | Select_range_check | 0 |
                      | Select_scan | 5070 |
                      | Slave_running | OFF |
                      | Slave_open_temp_tables | 0 |
                      | Slow_launch_threads | 0 |
                      | Slow_queries | 70 |
                      | Sort_merge_passes | 0 |
                      | Sort_range | 3401 |
                      | Sort_rows | 561837 |
                      | Sort_scan | 3240 |
                      | Table_locks_immediate | 23247 |
                      | Table_locks_waited | 9 |
                      | Threads_cached | 3 |
                      | Threads_created | 6 |
                      | Threads_connected | 3 |
                      | Threads_running | 2 |
                      | Uptime | 510 |
                      +--------------------------+----------

                      Thanks
                      Joanne

                      Comment


                      • #12
                        there's your problem your wait_timeout setting is too low at 600 seconds

                        i'd turn off pconnects in config.php change

                        usepconnect = 1

                        to

                        usepconnect = 0

                        and then ask if VO can increase their wait_timeout from 600 to 3600 and restart mysql - if they ask direct them to this explanation at http://www.vbulletin.com/forum/showt...265#post310265
                        :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                        :: Nginx SPDY SSL - World Flags Demo [video results]
                        :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                        Comment


                        • #13
                          Got the tech guys to do that, and I'm afraid to say that we still have the same problems

                          Joanne

                          Comment


                          • #14
                            Anyone???

                            Getting pretty desperate here

                            Joanne

                            Comment


                            • #15
                              Originally posted by eva2000
                              ssh in and type

                              Code:
                              mysqladmin -u mysqlusername -p variables
                              then copy and paste out here

                              then type

                              Code:
                              mysqladmin -u mysqlusername -p extended-status
                              then copy and paste out here
                              Post these results again.
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              Loading...
                              Working...
                              X