Announcement

Collapse
No announcement yet.

CGI Headers Error -- Cannot execute any PHP scripts!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • CGI Headers Error -- Cannot execute any PHP scripts!

    Was running vb 2.2.2 and tried to upgrade to 2.2.8.

    Copied files into the proper directories. When I try to run the various upgradexx.php files, I get:

    CGI Error

    The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are: [nothing]
    Also, when I go to my forums at: http://208.8.173.3/vb/upload/index.php

    I get nothing. Just a blank page.

    Things were running just fine before. Now, I can't do anything.

    My folder permissions have not been changed. It's as if my server can no longer recognize PHP?! HELP!

    (BTW, I cannot find anything via search to suggest a solution to this problem)

    Andy
    Andy Young

    vBulletin v2.2.2
    MySQL v3.23.42
    PHP v 4.0.6
    Windows NT Server

  • #2
    Is your server setup to run PHP as CGI? If so, then you'll need to add a line to each php file specifying the location of PHP. You may also need to chmod the files to 755. Check with your host to find out what's needed.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Isn't chmod a UNIX command? I'm running an NT server.

      It turned out to be permissions. I had set the folders for IUSR access. I double-checked this. I triple-checked this. I even toggled the permissions on and off and saw the server "attach" the permissions to the folder contents. I did this four times.

      I then checked a file and found that the permissions had NOT been written correctly. I tried setting them again. Three times later they had been written properly. Very, very, very odd ... I literally did the same couple of steps to set permissions, then checked a given .php file to see if the change had taken effect. At one point, it magically did.

      Thanks for your help.
      Andy Young

      vBulletin v2.2.2
      MySQL v3.23.42
      PHP v 4.0.6
      Windows NT Server

      Comment


      • #4
        My understanding is that some Windows servers use chmod. Could be wrong though. Anyway I'm glad you figured it out.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X