Announcement

Collapse
No announcement yet.

mysql error number: 2013

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • mysql error number: 2013

    I keep getting a lot of database error emailed. I've read the related topics and found out the problem. My hoster has a very low wait_timeout value. I asked if it was possible to increase this value, but they told me they kept it low because of the performance of the server.
    Is there another solution for the error ?

  • #2
    Not really, unless your host is willing to change the MySQL configuration. Frankly it sounds like he doesn't know how to optimize MySQL.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Re: mysql error number: 2013

      Originally posted by qmode
      I keep getting a lot of database error emailed. I've read the related topics and found out the problem. My hoster has a very low wait_timeout value. I asked if it was possible to increase this value, but they told me they kept it low because of the performance of the server.
      Is there another solution for the error ?
      how low is it set right now ?
      :: Always Back Up Forum Database + Attachments BEFORE upgrading !
      :: Nginx SPDY SSL - World Flags Demo [video results]
      :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

      Comment


      • #4
        I have no idea

        I emailed my host, but never got a reply. Can it harm the database if the problem persists ? Because I don't think they're willing to change the value. I hope it doesn't matter a lot......

        Comment


        • #5
          I got a reply

          It is set on 30 secs

          Comment


          • #6
            that's too low.. it needs to be set at least to 1800 to 3600
            :: Always Back Up Forum Database + Attachments BEFORE upgrading !
            :: Nginx SPDY SSL - World Flags Demo [video results]
            :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

            Comment


            • #7
              They won't do it....
              Can it harm the script and databases if it stays at this value ?

              So far the forum works just fine, the only thing that I notice is that I keep getting emails.

              Comment


              • #8
                Originally posted by qmode
                They won't do it....
                Can it harm the script and databases if it stays at this value ?

                So far the forum works just fine, the only thing that I notice is that I keep getting emails.
                it will cause mysql lost connection or mysql gone away errors especially when you have a server which isn't optimally configured and/or overloaded with shared virtual sites on a server

                i'd move hosts most hosts including effectonline.com and venturesonline.com have better optimally configured mysql server settings
                :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                :: Nginx SPDY SSL - World Flags Demo [video results]
                :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                Comment


                • #9
                  Originally posted by eva2000
                  that's too low.. it needs to be set at least to 1800 to 3600
                  Mine is set to 60 seconds.

                  Being NEW to this.. Can you tell me what I should tell my host and what does this value do for me if it were raised?

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X