Announcement

Collapse
No announcement yet.

Uploading Avatar Trouble

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Uploading Avatar Trouble

    When I try to upload custom avatars to my board I get this error message: "The uploaded file is not a valid GIF or JPG file. Please ensure that it is and try again."

    I have tried several different files that are all under the size limit that I've set.

    I am running vB version 2.2.7 and a here is the link to my phpinfo.php page. I am using safe mode and have it set to yes in the options and have specified a directory that has been chmoded to 777.

    If any of you can help me, it'd be greatly appreciated. Thank you.

  • #2
    Assuming you are using valid GIF or JPG files, the only thing I can think of is that the Safe Mode Directory you are using either doesn't exist or is not chmod'd to 777. Make sure you are using the full and complete path to that directory on the server.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      By 'Safe Mode Directory' do you mean the temporary upload dir?

      I have set the vBulletin Options -> Upload Options -> Safe Mode Temp Directory to '/tmp' and created a tmp directory under my forum directory assuming it was reletive from there. I've double checked that this directory has 777 permissions.

      Do I need an absolute path to that directory?

      Am I mistaking the starting point of the reletive reference or something?

      Comment


      • #4
        Originally posted by Psidefect
        I have set the vBulletin Options -> Upload Options -> Safe Mode Temp Directory to '/tmp' and created a tmp directory under my forum directory assuming it was reletive from there. I've double checked that this directory has 777 permissions.
        That's your problem. You need to use the full and complete path to that directory. Using '/tmp' points to a directory off the root directory of your server, not one under your forum directory.

        According to your phpinfo, that directory should be:

        /home/virtual/site179/fst/var/www/html/forum/tmp
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          That did it!

          Thank you so much for your time. You guys are awesome (and quick!) and you are appreciated.

          Comment


          • #6
            No problem!
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X