Announcement

Collapse
No announcement yet.

clean re-install with same data?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • George L
    replied
    Re: Miracle...

    Originally posted by della
    ...miracle of miracles, the forums are back up.

    I asked them to try and resize the memory allocation (or whatever is appropriate). I don't know if that's why it is now working cuz they haven't replied yet...

    Anyway, happy to see it up and know that it is not the db itself or vB/software problem.



    FYI:
    http://www.igda.org/Forums/


    Jason
    ask them to let you know what is in their /etc/my.cnf and also the out put of this command run as root user on the database box

    Code:
    mysqladmin -u root -p extended-status

    Leave a comment:


  • George L
    replied
    Re: BSD upgrade

    Originally posted by della
    ...ok, another bit of info from Pair support. They pointed me to their BSD upgrade notice:

    http://www.pair.com/pair/support/not...6-upgrade.html


    They also mentioned that the latest version of PHP4 (ie, 4.2.2) is stricter in enforcing resource limits, etc...

    Has vB 227 been tested fully with PHP 422?

    See anything of concern in the above notice?

    Jason
    yup if you use vB 2.2.7 i recommend PHP 4.2.3

    Leave a comment:


  • George L
    replied
    Re: yes, they restarted

    Originally posted by della
    ...ya, the host restarted the MySQL daemon after I nagged them that something was wrong.

    Since, all the queries going to the db is from vB, I don't think the incoming query is the problem. Rather, it would seem that it is running out of space when running simple queries on large tables (eg, user or post tables).

    Is there something to set in terms of allow more memory for "working space" on such queries...

    Also, I'm guessing that I do not need to do anything after a MySQL restart, correct?

    Jason
    you host needs to optimise /etc/my.cnf file settings for mysql usage but you restriction is the lack of memory and slow disk speed and cpu

    Leave a comment:


  • della
    replied
    Miracle...

    ...miracle of miracles, the forums are back up.

    I asked them to try and resize the memory allocation (or whatever is appropriate). I don't know if that's why it is now working cuz they haven't replied yet...

    Anyway, happy to see it up and know that it is not the db itself or vB/software problem.



    FYI:
    http://www.igda.org/Forums/


    Jason

    Leave a comment:


  • della
    replied
    BSD upgrade

    ...ok, another bit of info from Pair support. They pointed me to their BSD upgrade notice:

    http://www.pair.com/pair/support/not...6-upgrade.html


    They also mentioned that the latest version of PHP4 (ie, 4.2.2) is stricter in enforcing resource limits, etc...

    Has vB 227 been tested fully with PHP 422?

    See anything of concern in the above notice?

    Jason

    Leave a comment:


  • della
    replied
    yes, they restarted

    ...ya, the host restarted the MySQL daemon after I nagged them that something was wrong.

    Since, all the queries going to the db is from vB, I don't think the incoming query is the problem. Rather, it would seem that it is running out of space when running simple queries on large tables (eg, user or post tables).

    Is there something to set in terms of allow more memory for "working space" on such queries...

    Also, I'm guessing that I do not need to do anything after a MySQL restart, correct?

    Jason

    Leave a comment:


  • George L
    replied
    Re: smooth upgrade

    Originally posted by della
    ...yes, I ran all the upgrade scripts from 13 to twenty. Each one ran fine.

    I also, re-uploaded all the main files and admin files, etc (yes, in ASCII mode).

    Also, I just got word from our host that they restarted the mysql daemon on the server and all seems to be in good shape server-wise (note that my site/php is running on a separate server).

    Yet, the forum is not coming up:
    http://www.igda.org/Forums/index.php

    Also, the admin page is not coming up either
    http://www.igda.org/Forums/admin

    The database itself does seem to be alive, and I can query it with simple queries. However, if I try to "browse" the user table (approx 14k records) from within phpMyAdmin, I get the following error page:


    **********
    Warning: MySQL: Unable to save result set in /usr/www/users/cgda/newigda/admin/phpMyAdmin/sql.php on line 60
    Database cgda_forums - table user
    Error
    SQL-query:
    SELECT * FROM user
    MySQL said: Lost connection to MySQL server during query
    **********


    So, it seems like it is still having some memory troubles... Note that browse works fine for smaller tables...

    Anyway, part of my concern is that the tables did not update properly during all this memory funkiness...

    Another question, can I do a fresh install and then import existing threads/posts/users, etc? Will version 3 support that?

    PS: If you email me ([email protected]) with you phone number, I'll buzz you for a quick chat... There are bunches of video game developers itching to get back online...

    Jason
    lost connections error are another sign of inadequately configured mysql server

    http://www.mysql.com/doc/G/o/Gone_away.html
    http://www.mysql.com/doc/C/o/Common_errors.html
    http://www.mysql.com/doc/S/e/Server_parameters.html
    http://www.mysql.com/doc/O/p/Option_files.html
    http://www.mysql.com/doc/S/H/SHOW_VARIABLES.html

    The most common reason for the MySQL server has gone away error

    1. Is that the server timed out and closed the connection. By default, the server closes the connection after 8 hours or 28800 seconds if nothing has happened. You can change the time limit by setting the wait_timeout variable when you start mysqld via your server's /etc/my.cnf as well.

    2. Another common reason to receive the MySQL server has gone away error is because you have issued a ``close'' on your MySQL connection and then tried to run a query on the closed connection. You can check that the MySQL hasn't died by executing mysqladmin version and examining the uptime.

    i.e. to check mysql uptime, in shell as root user type:

    mysqladmin -u root -p version

    3. You can also get these errors if you send a query to the server that is incorrect or too large. If mysqld gets a packet that is too large or out of order, it assumes that something has gone wrong with the client and closes the connection. If you need big queries (for example, if you are working with big BLOB columns), you can increase the query limit by starting mysqld with the -O max_allowed_packet=# option (default 1M) or via max_allowed_packet variable in your /etc/my.cnf file and restarting mysql after you edited your /etc/my.cnf file. The extra memory is allocated on demand, so mysqld will use more memory only when you issue a big query or when mysqld must return a big result row

    4. or simply your host restarted mysql.. i'd contact your web host

    Leave a comment:


  • della
    replied
    smooth upgrade

    ...yes, I ran all the upgrade scripts from 13 to twenty. Each one ran fine.

    I also, re-uploaded all the main files and admin files, etc (yes, in ASCII mode).

    Also, I just got word from our host that they restarted the mysql daemon on the server and all seems to be in good shape server-wise (note that my site/php is running on a separate server).

    Yet, the forum is not coming up:
    http://www.igda.org/Forums/index.php

    Also, the admin page is not coming up either
    http://www.igda.org/Forums/admin

    The database itself does seem to be alive, and I can query it with simple queries. However, if I try to "browse" the user table (approx 14k records) from within phpMyAdmin, I get the following error page:


    **********
    Warning: MySQL: Unable to save result set in /usr/www/users/cgda/newigda/admin/phpMyAdmin/sql.php on line 60
    Database cgda_forums - table user
    Error
    SQL-query:
    SELECT * FROM user
    MySQL said: Lost connection to MySQL server during query
    **********


    So, it seems like it is still having some memory troubles... Note that browse works fine for smaller tables...

    Anyway, part of my concern is that the tables did not update properly during all this memory funkiness...

    Another question, can I do a fresh install and then import existing threads/posts/users, etc? Will version 3 support that?

    PS: If you email me ([email protected]) with you phone number, I'll buzz you for a quick chat... There are bunches of video game developers itching to get back online...

    Jason

    Leave a comment:


  • George L
    replied
    Re: clean re-install with same data?

    Originally posted by della
    Hi,

    I've been having funky server problems for the past day or so. It seems like MySQL was complaining about memory issues. Anyway, I updated my vB installation from 203 to 227. But, even though everything seemed to update/install fine, I have the suspision that something is not right.

    First, the situation got worse after the install, and the entire forum and admin page is totally fubar (when running 203, I was at least able to access the main admin page).

    So, question is, can I do a "clean re-install" of 227 to ensure all the files are present and the tables up to date, while keeping all the current data intact?

    Or, should simply copy all the files from the zip help?

    Jason
    i'd read the reply i gave you at http://www.vbulletin.com/forum/showt...041#post349041

    Leave a comment:


  • Steve Machol
    replied
    Reinstalling would empty the database so that's not what you want. When you upgraded from 2.0.3 to 2.2.7 did you run ALL the required upgrade scripts from upgrade13.php through upgrade20.php? If so, did you encounter any errors along the way?

    Also you might want to reupload the original 2.2.7 php files. Make sure you upload in ASCII and overwrite the ones on the server.

    And finally since many templates have changed since 2.0.3, you should probably start off with a fresh set of original template.

    If you still have problems after all this, please post exactly what's happening.

    Leave a comment:


  • della
    started a topic clean re-install with same data?

    clean re-install with same data?

    Hi,

    I've been having funky server problems for the past day or so. It seems like MySQL was complaining about memory issues. Anyway, I updated my vB installation from 203 to 227. But, even though everything seemed to update/install fine, I have the suspision that something is not right.

    First, the situation got worse after the install, and the entire forum and admin page is totally fubar (when running 203, I was at least able to access the main admin page).

    So, question is, can I do a "clean re-install" of 227 to ensure all the files are present and the tables up to date, while keeping all the current data intact?

    Or, should simply copy all the files from the zip help?

    Jason

Related Topics

Collapse

Working...
X