Announcement

Collapse
No announcement yet.

Postings messing up - dupe threads with blank posts

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Postings messing up - dupe threads with blank posts

    Having a problem on my forums where someone will make a post as normal, but if it is a reply then about 3 or 4 blank replies by that person will appear in the thread, or if it is a new post 3 or 4 posts will appear in the forum, but when you read them there is no post at all. (see picture for example)

    This is an example:
    http://www.gurn.net/forums/showthrea...hreadid=114559

    http://www.gurn.net/forums/showthrea...hreadid=114560

    http://www.gurn.net/forums/showthrea...hreadid=114561

    http://www.gurn.net/forums/showthrea...hreadid=114562


    This happened last week occaisionaly, and then we had an outbreak of it occuring lots. A while later the board was completely screwed and mySQL was reporting that the searchindex table had crashed. We closed the boards, turned off search and dropped the searchindex table. Made a new blank table and opened the board again. This weekend we set the forums off recreating the search index, and I believe it is still going (1.5m posts), although searching of the board is still disabled.

    We hope that we had eliminated what was causing the problems, but it appears this week they are back again.

    Can someone please help shed some light on this as I am truly puzzled. This is a very busy forum and we really can't afford any more downtime, or risk loosing our data.

    Thanks,
    Meirion.

  • #2
    P.S. Since this error has occured again this morning the forums have been running very slowly compared with normal. I am on a 2mb adsl line and it's noticeably slower compared with normal.

    Comment


    • #3
      er, hello? We have a problem here, can somebody help please!

      Some aknowledgement would be nice.

      Comment


      • #4
        Image of error

        Comment


        • #5
          If you have not applied any hacks, fill out a support ticket at:

          http://www.vbulletin.com/members/support_form.php

          Be sure to include the login info to your Admin CP and FTP.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            They are redirects to moved posts... Where are they showing up at? In the thread list they should redirect to the actual thread.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud demonstration site.
            vBulletin 5 API

            Comment


            • #7
              Thanks for the reply.
              This picture is an example of what happens.

              The four posts will appear all at once, right after each other, and none of them will actually contain the first post. If you reply then the 1st post at the top of the thread will be that 1st reply.

              This picture shows two of the threads next to each other with no replies (My Pubes itch like crazy - by Turbo), and further up there is one of them with some replies. FYI, the fourth thread is more recent on my board as it got some more replies.

              They are not redirects, they should be normal posts/threads. But where are there four of them, and why is there no first post?

              Comment


              • #8
                It tends to happen when the poster clicks the Submit button frantically instead of a civilized single click.
                --filburt1, vBulletin.org/vBulletinTemplates.com moderator
                Web Design Forums.net: vB Board of the Month
                vBulletin Mail System (vBMS): webmail for your forum users

                Comment


                • #9
                  test

                  Comment


                  • #10
                    Originally posted by filburt1
                    It tends to happen when the poster clicks the Submit button frantically instead of a civilized single click.
                    So the answer is to ask my members to be 'more civilized'? I'm almost certain that is not the cause of this problem.


                    (my test post above had about 20 frantic clicks on the Submit Post button)

                    Comment


                    • #11
                      I was referring to posting new threads, not new replies.

                      Upgrading to 2.2.7 might fix the problem; I've seen this before on many older boards.
                      --filburt1, vBulletin.org/vBulletinTemplates.com moderator
                      Web Design Forums.net: vB Board of the Month
                      vBulletin Mail System (vBMS): webmail for your forum users

                      Comment


                      • #12
                        The problem has recurred again, but I have been thinking about it more.

                        If the mySQL server is heavily loaded, could it be that VB submits the new thread details to the database, and doesn't get a response quick enough, so submits the details again (and again) until it gets a response, by which time 2 or more threads with identical data have been created?

                        The reason I say this is that the forum is currently recreating the search index, which will obviously be taxing the db to the max.

                        Comment


                        • #13
                          No.... Once submitted vBulletin waits.

                          You will have to open a support ticket and give admin and FTP login information as well as a way to access the database directly like phpmyadmin.
                          Translations provided by Google.

                          Wayne Luke
                          The Rabid Badger - a vBulletin Cloud demonstration site.
                          vBulletin 5 API

                          Comment


                          • #14
                            Ok will do that this weekend. Thank you Wayne

                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X