Announcement

Collapse
No announcement yet.

Call to undefined function: mysql_connect()

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • midknight
    replied
    well heres the thing. i got kindof fed up...
    walked away for a couple hours, came back and then it worked...

    something must have been cached.
    i changed the name of the database...
    and then the next step would tell me that the database already existed...

    i was dumping the cache and history in internet explorer everytime too.
    it was kindof wierd

    Leave a comment:


  • George L
    replied
    Originally posted by midknight
    ok im getting further

    http://www.autoloc.ca/forums/admin/phpinfo.php

    http://www.autoloc.ca/forums/admin/mysqlinfo.php

    i now appear to have php compiled correctly....
    mysql appears to be compiled correctly...

    new problem is that i cannot get past step4 of the install.



    ive been playing around for hours now.
    please make the pain stop
    you should of viewed the source code on error page to see what was wrong... since you only installed i suggest you redo the install with a new empty database... this time when you get an error like that right click on page and view the mysql error message

    Leave a comment:


  • midknight
    replied
    hmm fixed it somehow...
    works like a dream
    thanks

    Leave a comment:


  • midknight
    replied
    ok im getting further

    http://www.autoloc.ca/forums/admin/phpinfo.php

    http://www.autoloc.ca/forums/admin/mysqlinfo.php

    i now appear to have php compiled correctly....
    mysql appears to be compiled correctly...

    new problem is that i cannot get past step4 of the install.

    There seems to have been a slight problem with the database.
    Please try again by pressing the refresh button in your browser.

    An E-Mail has been dispatched to our Technical Staff, who you can also contact if the problem persists.

    We apologise for any inconvenience.
    ive been playing around for hours now.
    please make the pain stop

    Leave a comment:


  • George L
    replied
    Originally posted by midknight
    should i use this format when compiling?



    or do i need to include the --with-apache tag?
    repost your phpinfo page.. all you need to do is copy the current configuration but change one item

    Code:
    --with-mysql=shared,/usr
    change to


    Code:
    --with-mysql=/usr

    Leave a comment:


  • midknight
    replied
    should i use this format when compiling?

    ./configure --with-apache=/path/to/apache/dir --with-mysql=/usr/local/mysql
    or do i need to include the --with-apache tag?

    Leave a comment:


  • midknight
    replied
    i did install mysql...
    and from the results of that mysqlinfo.php file i think its running.

    Leave a comment:


  • Steve Machol
    replied
    Originally posted by midknight
    i did the ./configure --with-mysql=/usr

    are there other options in the compile that need to be included?
    Configuring PHP for MySQL support is not the same thing as installing MySQL on that server. Did you install MySQL, and is it running?

    Leave a comment:


  • midknight
    replied
    ok:
    http://www.autoloc.ca/forums/admin/mysqlinfo.php

    PS. thanks for the help thus far

    Leave a comment:


  • midknight
    replied
    i did the ./configure --with-mysql=/usr

    are there other options in the compile that need to be included?

    Leave a comment:


  • Steve Machol
    replied
    I didn't see any MySQL info listed in your phpinfo. Are you sure you're running MySQL on that server? Upload mysqlinfo.php (it's in the 'extras' folder of the zip file) to your admin directory. Then post the URL here.

    Leave a comment:


  • George L
    replied
    Originally posted by midknight
    yep thats my phpinfo...
    im going to start from scratch again...
    beginning with mysql something is messed up here....
    nothing to do with mysql .. only to do with PHP and it's compilation

    Leave a comment:


  • midknight
    replied
    yep thats my phpinfo...
    im going to start from scratch again...
    beginning with mysql something is messed up here....

    Leave a comment:


  • George L
    replied
    Originally posted by midknight
    i did that Eva...
    no change
    still getting
    is this your phpinfo page http://www.autoloc.ca/forums/admin/phpinfo.php cause it still says Aug 21, 2002 built meaning you haven't recompiled php properly... did you restart apache after ?

    Leave a comment:


  • midknight
    replied
    i did that Eva...
    no change
    still getting

    Fatal error: Call to undefined function: mysql_connect() in /home/www/autolocphp/forums/admin/db_mysql.php on line 40

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X