Announcement

Collapse
No announcement yet.

Call to undefined function: mysql_connect()

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Call to undefined function: mysql_connect()

    here is the full error i get...

    Fatal error: Call to undefined function: mysql_connect() in /home/www/autolocphp/forums/admin/db_mysql.php on line 40

    this is on step 3 of the installation

    i have installed apache and php and mysql...
    im running the server
    RED HAT 7.3
    and i can connect to the mysql server on the host...

    the only thing that i have seen that i don't have is the:
    mysql-DBI-perl-bin-1.825-1.i386.rpm

    and im still trying to download it now..

    any help would be great
    thanks

  • #2
    Well as the requirements stated MySQL is a critical part of vBulletin...

    Make sure you compiled PHP with MySQL support.
    --filburt1, vBulletin.org/vBulletinTemplates.com moderator
    Web Design Forums.net: vB Board of the Month
    vBulletin Mail System (vBMS): webmail for your forum users

    Comment


    • #3
      post your phpinfo details or link seems you don't have mysql support compiled into PHP
      :: Always Back Up Forum Database + Attachments BEFORE upgrading !
      :: Nginx SPDY SSL - World Flags Demo [video results]
      :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

      Comment


      • #4
        here is my phpinfo:

        http://www.autoloc.ca/forums/admin/phpinfo.php

        i have compiled php with the "--with-mysql=/usr"
        and i have installed all the mysql rpms that i could find...

        Comment


        • #5
          If it's anything like my phpinfo then there should be a whole separate section for MySQL, which doesn't seem to be in yours.
          --filburt1, vBulletin.org/vBulletinTemplates.com moderator
          Web Design Forums.net: vB Board of the Month
          vBulletin Mail System (vBMS): webmail for your forum users

          Comment


          • #6
            hmm, ok.

            am i doing something wrong in my compile of php then?
            i followed the instructions from another thread ill have to find it again where it worked for the person.

            Comment


            • #7
              Originally posted by midknight
              hmm, ok.

              am i doing something wrong in my compile of php then?
              i followed the instructions from another thread ill have to find it again where it worked for the person.
              1. in PHP source directory delete the config.cache file
              2. recompile php and replace the part

              Code:
              --with-mysql=shared,/usr
              with

              Code:
              --with-mysql=/usr
              and restart apache
              :: Always Back Up Forum Database + Attachments BEFORE upgrading !
              :: Nginx SPDY SSL - World Flags Demo [video results]
              :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

              Comment


              • #8
                i did that Eva...
                no change
                still getting

                Fatal error: Call to undefined function: mysql_connect() in /home/www/autolocphp/forums/admin/db_mysql.php on line 40

                Comment


                • #9
                  Originally posted by midknight
                  i did that Eva...
                  no change
                  still getting
                  is this your phpinfo page http://www.autoloc.ca/forums/admin/phpinfo.php cause it still says Aug 21, 2002 built meaning you haven't recompiled php properly... did you restart apache after ?
                  :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                  :: Nginx SPDY SSL - World Flags Demo [video results]
                  :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                  Comment


                  • #10
                    yep thats my phpinfo...
                    im going to start from scratch again...
                    beginning with mysql something is messed up here....

                    Comment


                    • #11
                      Originally posted by midknight
                      yep thats my phpinfo...
                      im going to start from scratch again...
                      beginning with mysql something is messed up here....
                      nothing to do with mysql .. only to do with PHP and it's compilation
                      :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                      :: Nginx SPDY SSL - World Flags Demo [video results]
                      :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                      Comment


                      • #12
                        I didn't see any MySQL info listed in your phpinfo. Are you sure you're running MySQL on that server? Upload mysqlinfo.php (it's in the 'extras' folder of the zip file) to your admin directory. Then post the URL here.
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          i did the ./configure --with-mysql=/usr

                          are there other options in the compile that need to be included?

                          Comment


                          • #14
                            ok:
                            http://www.autoloc.ca/forums/admin/mysqlinfo.php

                            PS. thanks for the help thus far

                            Comment


                            • #15
                              Originally posted by midknight
                              i did the ./configure --with-mysql=/usr

                              are there other options in the compile that need to be included?
                              Configuring PHP for MySQL support is not the same thing as installing MySQL on that server. Did you install MySQL, and is it running?
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X